compile collection: how to hold on to an adapted order

I have added a series of texts from draft folder (rather extensive summaries) to a collection ; I added these to the collection in several batches, but also one after the other. I could change the sequence in the collection by using ‘control+arrow up’. e.g.: I forgot to add number ‘4’; after adding to the collection it appears after number ‘20’. I put it in the right place between number ‘3’ and ‘5’.
Now I want to compile the collection and transfer to Word. But in the compile-mode it does not hold on to this adapted order, so number 4 is last again.
Is there a trick how to keep the order I want to have?
Hope you can help.

Hi, Selma,

I would also have expected this to work as you mention. But I tried and it didn’t work for me either on Windows.

Doing some research in the forum I found this thread which makes me think that the lack of the filtering compile capabilities of the Windows version precludes the desired result. :cry:

But I’m just a regular user. Maybe some support fellows can enlighten us.

Thanks for catching this. Collections should compile using the order you’ve assigned, not their original order. It looks as though there’s a problem saving the new collection order, affecting not just compile but the collection order when the project is reopened. I’ve filed a bug report for the issue.

Thans for this answer. I have found a way to cope with it. I put a * in each text with my summaries. I collect these with the search option. The will keep the right order. A rather roundabout, but for the rest of my work I can stick to this method.

Just an update to this, how were you rearranging the collection? In fixing the bug I did some further testing and it seems as though using the mouse to drag and drop collection items into a new order preserves the order in compile, whereas using the keyboard shortcuts or the menu for the Up/Down commands was losing the order. If you were using those shortcuts, using the mouse to rearrange the items in the collection might be a workaround for you until the update.

It seems to be worse than before in December. That’s why I returned to the forum. I did not use shortcuts.
This time I collected all files with a * in title: search results are in the right order. Next, I collected all search results (control A) and added to a collection. This becomes a mess in a complete different order! Please help!

Why not just save the search results using the “Save as Collection” option at the bottom of the search menu? This will run the search each time you load the collection, keeping the results up to date and in the current binder order.

This works better. I did not notice this option before. Also if I compile this collection it stays in the right order. Thanks.

Is there any indication when this bug will be solved. I am using collection for different purposes, this bug is annoying.

This has been fixed in the current public beta, which you can download from the beta forum. The current beta expires 01 March, so you may want to wait for, which will be out within the next couple days.