Compile doc results in one letter per line

Hello,

I’m experiencing an issue that was identified years ago, in this post (https://forum.literatureandlatte.com/t/compile-to-word/13370/1) but I haven’t seen any fix that is still relevant, given that a lot of the feedback refers to compile settings that no longer appear.

I’ve been using Scrivener on Mac for years and never had any issue with compiling documents, until a recent Scrivener update. Now, a file that I had previously compiled without issue ends up as just one giant string of letters that runs down the left column in word. I’m not able to click on the slider in Word to change the right indent, as was previously suggested. I have tried compiling as PDF, rtf, .doc, and .docx, all to the same result. I think this has something to do with the margins settings in Scrivener, but I can’t figure out what.

My standard page size in Word is A4, which is what I also have Scrivener set to.

What I did:

  1. Compile doc. I selected .docx. I tried both selecting and deselecting “add front matter”. It works a little better with front matter selected, in that the metadata appears to have better margins
  2. Compile document.
  3. I checked the compile in both word, .rtf, and PDF. Each time the results were the same.
  4. I finally managed to adjust the page settings in word to have it reselect A4 size. This then made the margins appear a little, but I still had to tinker with them a lot before I had anything workable. But I need to figure out what’s going wrong on the compile/Scrivener end in my settings to avoid the problem in the future.

Any help is greatly appreciated! Thank you!



Yeah, the thread linked to was for the Windows 1.x beta version, so I’m not surprised it’s not much help here. :wink: The easiest way to work through this would probably be if you could provide a sample project demonstrating the issue. You can use “Save As” to make a copy of your current project, then strip it down to a document or two (or create a new document, so long as compiling it demonstrates the issue). Make sure that you’re still getting the issue when you run compile, then use File > Back Up > Back Up To… with the ZIP option checked to create an archived copy you can upload here. After that you can trash the sample project and go back to your original.

Alternatively, you could email a copy of the project to the tech support address if you can’t create a stripped down version to post here and are concerned about any data in it. Include “Attn: MM” in the subject line so I can keep an eye out for it.

Hi Jennifer,

I’m sorry, I didn’t see that there was a reply to my question until now, the next time I attempted compiling a newer version of the project. (I’m still having the same compile issues). Thank you for your response.

I’ve created a test version here and it is still having the same identation issues. I appreciate any insight you may have! Thank you in advance.

Compile issue sample project 2020-08-27 12-12.zip (438 KB)

Best,
Ellen

Hi Ellen, This is certainly curious. I don’t have Word for Mac, but the sample docx I compiled from your project with the given settings opens for me in both Pages and Word for Windows with the text looking as it should do. Could you open the attached docx and let me know if it’s still wrong for you or if this one looks correct?

Under Scrivener > Preferences > Sharing, are either of the top two checkboxes selected under the Conversion tab? I’d try playing around with these to see if that’s affecting things. Any combination is working for me, but the second will be affected by which version of Java is installed on the system, so that may be different for each of us. What version of macOS are you using? And which version of Scrivener?

Also, I wasn’t clear from your initial post–what happens if you change the indentation settings for a paragraph in the compiled document within Word? Even if you can’t drag the markers on the ruler, you should be able to do this via the Paragraph dialog.
Compile issue sample project.docx.zip (16.6 KB)

Hi Jennifer,

Thanks for looking into this. I can open your Word document just fine. It looks normal.

I’ve tried toggling the preferences about the Java under conversion, but that doesn’t seem to make a difference. And when I try changing the paragraph alignment or indentation in Word, it gives me an error message “indent too large”, regardless of what the indent is set to, even if I don’t touch this particular field.

I use Word for a lot of other things, and have never had this issue before, so I’m not sure what’s going on. Here is how the document looks on my end. (If it opens the same way for you as it does for me, that is.)
Compile issue sample project2.zip (16.6 KB)

I’m using Mac High Sierra 10.13.6 and Scrivener 3.1.5

Thanks again!
Elln

Hi Ellen – OK! That document helped a lot, thank you. I do get the weird results, and it appears to be down to a very odd paper size. If you open it in Word and open the Page Setup dialog, you should be able to change the Paper Size to A4 or whatever it is you want it to be, making sure to apply the change to the whole document and not only “this section”. You mentioned in your first post that you played around with this a bit and got it looking partly correct. Could you try again with this sample text, simply opening it in Word and changing and applying the A4 paper size to the full document, and then let me know what specifically still isn’t right? For me it seems to resolve the issue entirely, so I’m hoping this has at least brought us to the crux of the problem, but if there’s still more to be done in your case, we’ll need to figure that out.

The question of course is why the compiled document is coming out without the correct paper setting. If you’re using the built-in “Manuscript (Times)” compile format without any alterations, it should be using the default paper size set in your system printer preferences. So as a first step, I’d open up System Preferences > Printers & Scanners and check what’s currently set as the default paper size for your default printer. Try resetting it to A4.

Quit and restart Scrivener to be sure it grabs the new printer settings, then open compile for your project. You can try giving it a go now, or else double-click the “Manuscript (Times)” compile format, choose Duplicate & Edit, then select “Page Settings” on the left. At the top of that pane it should have “Use default paper size” selected and show you what size that is–it should be what you just set your printer to, and if it is, you can just Cancel and then compile

If the page size does not look right, deselect the checkbox and click the “Page Setup” button, then choose A4 from that list and click OK. (You may not even need to do that–deselecting the checkbox will probably bounce it straight to A4 already, but you could select something different via the Page Setup at this point.) Once the paper size is showing correctly in the Page Settings pane, go up to the top of the window and change the Format Name if you want (it appended “Copy”, but you might want to change that to specify the paper size, for instance), select “My Formats” from the second drop-down so that your modified compile format will be available to all your projects, and then click Save at the bottom right of the window.

Now try the compile with your adjusted format. Does that open correctly?

Hi Jennifer,

Wow, yes, these steps fixed the issue! Thank you very, very much for all your help. :smiley: It’s a big relief to have this looking back to normal. I wouldn’t have known what to do with my manuscript otherwise.

Thank you for all your time with this.

Take care,
Ellen