Compile does not return correct format

I’m having some issues with compiling. I have created a custom format, and in section layouts, I have set things up so that all section types “override text and notes formatting.” However, when I compile, the results do not conform to the formats I set up in the section layouts.

I can confirm that I have selected the correct section type in the compile window.

I have not had this problem in the past ever, so I’m wondering if someone has an idea for me.




I’d have a look at §17.1, Think Different, in the user manual PDF, and see if that describes what you have in the main editor. Heavy style dependency means having to do more setup in the compiler in order to work around its inherent baseline assumption that what you style should stay formatted that way all through compile.

If you do need these styles, you’ll need to get familiar the Styles compile format option pane, and have a look at how some of the other Formats are set up, that do widespread modification of formatting (like Manuscript Courier).


In my experience, this happens — by design — in relation to styles. If you’ve applied a paragraph and/or character style to your text, the style overrides layout formatting.

It surprises users who’ve decided, for instance, to use a “body” style for almost everything. Literature & Latte doesn’t recommend doing that, but it’s not a show-stopper. If you add the style in Compile, you can change its format there and get the result you want.


Thanks for this! I’ll be sure to keep this in mind as I move forward.

Thank you! So, would you say it’s better to style in the editor and not have the compiler use that formatting?

Opposite. Minimise styles in Editor, and rely on compiler settings to format your deliverable.

1 Like

Framed as you put it, I would struggle to answer that question concisely, because I wouldn’t know the context. For some things I would agree, like an epigraph, it might make sense to style in the editor and not bother with changing how it looks in the compiler. You always could, if you wanted, you aren’t stuck with your choice, as making the compiler change what epigraphs look like is a simple configuration adjustment.

But generally speaking, for paragraphs such as what I’m typing in now, I would give the same advice I gave in the user manual in the referenced section (§17.1). It is better to not use styles so that the compiler has simplified control over how your text looks on output.

It is a bit of a Catch-22 because on the one hand we’re tying to make it easier for you to not worry about formatting while writing, but it does require some awareness of that concept. If you just forge ahead like you would in LibreOffice or MS Word, things get more complicated and you have to do more configuration when you compile—otherwise you get the result you described: the compiler doesn’t seem to work as advertised even though it seems to be set up right. Because ultimately you are telling the compiler, with how your text is styled, that this is definitely what you want it to look like.

Hopefully that makes more sense.

1 Like

You are not using styles to format your text.
You are using styles so that the compiler knows you want this and that specific chunk to look (be formatted) their own way, apart from the overall body text. (“their own way” being here the key part.)
Of course, using a style does format the text, so what I just said might look like I am playing on words. But I am not.
Have this for a thought process regarding why style this and not that, and the reason is then clear.

I compile as-is for the most part but use Compile settings to add titles, chapter numbering, and pov-specific header images. I format the text in Compile only when everything in a document should be italics bold, or centered, for instance.