Compile doing nutty things with scenes

It seems no matter what I do, random scenes are being broken out into their own chapters. I don’t understand why compile (I’m trying to import to Vellum) is being so crazy. I’ve never had these problems before.

There should be 27 chapters, but the compiled .docx has randomly decided a few scenes should be chapters on their own.

Does anyone have any idea how to remedy this?

First of all, which version of Scrivener are you using (Version 2 or 3)?

If it’s V3, then the first thing which springs to mind is that some of your scenes have been allocated the wrong Section Type, so that the compiler is treating them as Chapters, not Scenes (the names of the Section Types may be different, but the principle is the same). The easiest way to test this is to compile and look in the right hand box of the first screen — do all your scenes have the right Section Type? If not, you can correct them in that pane and do a test compile to make sure it’s worked. But it’s better to correct the problem in the binder — highlight the offending scenes, right click on them and choose the correct Section Type.

If that’s not the problem, then we’ll probably need a few more details to see what’s going on.

Thanks for the reply. I’m using 3.0.3.

It doesn’t seem to matter if I have “structure based” or “scene” selected in the binder (or in compile). A few errant scenes end up as untitled chapters.

The book is only chapters and scenes. No parts or other sections. I’m trying to export a .doc/.docx. It’s really odd.

I’ve attached a snapshot of some of the compile window. One of those scenes is being broken out as its own chapter, but the settings for it are the same as the rest.

sample of compile window.jpg

It does look ok on the face of it. Just a couple of questions… In that screenshot, which is the errant scene?

Secondly, what’s the difference between Chapter and Chapter Heading?

Just to eliminate any variables, I’d make them all either structure based or manually allocated, but I can’t think how rpthat would cause a problem really.

One other thing, when you say the errant scenes are appearing like chapters, do you mean they have exactly the same appearance as normal chapters (heading, number etc) or just that they start on a new page?

(Sorry it’s late here and I’m off for the night, so I won’t pick up the thread till tomorrow - hopefully someone else will be able to help before then…j

Thanks again for the reply.

Honestly, I have no idea what the difference is between Chapter and Chapter Heading. I was trying different settings to see if it made a difference. It didn’t.

The errant scene in that shot is “Leroux is angry.” The few that this happened to were the last scene in a chapter. That’s about the only commonality I see.

The errant scenes are broken out like they are chapters but have no chapter heading just the scene divider *** at the top. Start on a new page so Vellum reads them as a new chapter.

I will try again with all structure based (how it was originally when I ran into this issue) and manually allocated. I’ve tried with various format (vellum export and manuscript) and they all turn out the same.

Thanks for your time.

Hi Monique,

I’m on Windows 1.9, so don’t know v3 compile and can’t suggest anything specific.

I couldn’t help but notice though that the errant Leroux scene in your screenshot seems to be categorized differently than your other scenes. The word “Scene” is italicized for the scene, and it isn’t for the other ones.

I haven’t a clue what that means or whether it is significant to your issue, but thought I’d point it out, in case that helps you figure it out.

Jim

Hi Jim,

Thanks for the reply. When you assign manually, it unitalicizes the word. I was trying a mixture of manual and structure based, to no avail. Didn’t see any difference with Chapter or Chapter Header either.

Iz puzzlement.

Hi Monique,

Have you checked that you have no actual page breaks inside the files themselves? You say that you broke things out into chapters - did you perhaps import your text from elsewhere that might have had page break sin the text? To check, please try this:

  1. Open one of the problem documents in the editor.

  2. Switch to page layout view (View > Text Editor > Show Page View.

Now look through and see if there are any breaks at unexpected places and delete them if so.

If that still doesn’t help, please zip up the project and send it to us at Mac.support AT literatureandlatte.com so that we can take a look at what is going on.

All the best,
Keith

Hi Keith,

Thanks for the reply. I took a look and don’t see any page breaks.

I’ve sent the .zip and a sample compile .doc to the address you listed.

Thanks for any help you can provide.

Best,
Monique

Thanks for the file. The problem is pretty simple, fortunately: you have extra blank lines at the end and beginning of some documents, and Vellum is interpreting them as a chapter break.

For instance, take a look at the start of “Leroux is angry”. There’s a blank line right before the first line (you can go to View > Text Editing > Show Invisibles to make these more obvious). Then if you look at the very end of the document preceding “Leroux is angry” - “Artemis & Phoebe at Quills” - you will see that there are two blank lines at the very end of the document. All those blank lines are causing your scenes to be treated as chapters by Vellum.

So, all you need to do to fix this is go through the problem scenes in Scrivener and delete any blank lines from the start or end of documents. You can automatically delete trailing space from documents by ticking “Delete trailing whitespace from documents” in the Compile options, but there is no equivalent for empty lines at the start of documents, which is assumed to be deliberate, so you’ll need to clean up manually.)

Once you’ve done that, everything should export perfectly.

All the best,
Keith

Hi Keith,

Thank you! That did fix the issue. It is a little odd for it read multiple lines as a new chapter, but I’m just relieved to know what the heck was happening!

I will certainly be aware of this in the future. Appreciate your help.

Monique

Glad you’re on track!
All the best,
Keith