Compile don´t keep Centered text. Scrivener 3

Hi there

Hope you can help me.
At the end of my novel the word FIN is not center nor the image of a cover which is located below.
Preserve formate doesn´t work.
I am putting style Centered text and it works but modify the beginning of the all paragraphs. Instead of center paragraph I got the first line moved to the right.
What can I do?

Thanks

It sounds as though the centred text has a first line indent - this will cause it to be offset a little, because the first line indent will push it across. So remove the first line indent from the ruler for centred text.

All the best,
Keith

Hi Keith

Thank you so much for your reply. However I need a little more help.
First question, do I have to delete all the first line indent one by one? And second question. As you see in the screenshot, I only see one first line indent. If I have to remove it all the paragraphs will be modified, right?

Big thanks

Hi,

If I understand correctly, you only want to this fixed for titles, right? If so, you just need to remove the indent in the Section Layout in Compile - are you using a custom Compile format?

All the best,
Keith

Hi, Keith

If you mean the first paragraph below the title and after the break scene, yes.
Attached are the screenshots of the styles, custom format. So “nuevo” styles is the one I have to remove the indent?

Big thanks!!


Sorry, I’m a little confused as to what you are trying to do. I thought your problem was that text is not being centred properly, but now you seem to be talking about removing indents from the first paragraph after a break. If you just want the first paragraph indent removed from the “Nuevo” style, you can just tick “Flatten first indent” in the options for that style (you can see the option in the screenshot you posted).

That doesn’t seem to have anything to do with the problem of text not being properly centred reported in your first post, though.

All the best,
Keith

Hi Keith

The problem now is fixed thanks to your last advice. The problem was that after I put the middle text, the first paragraphs after title were modified. Now everything is fine.

Please, one more problem.
If you see the screenshots, you will see that the space between scenes are different. Now the space is smaller than before, because I went to the editor, went to the scene to “delete” the space between the last word and last part of the page. So, right now, I have a novel with different space between scenes. How can I fix it?

Big thanks!!



If there’s different space between the scenes, don’t you just need to go to the other scenes and do the same? Scrivener will only insert one blank line between scenes, so anything else must be in the project, I would have thought. Isn’t the second Kindle Previewer screenshot exactly how things should look?

All the best,
Keith

Hi, Keith

The idea to check all the scenes of my novel to modify the space deleting blank lines is something overwhelming to say at least. I don´t recall something similar on Scrivener 2. So from now I have to be careful when copy and paste one text from one scene to another, because I will leave a blank space. That is very frustrating and a huge waste of time.

Must be another solution.

Big thanks

You may find the Edit -> Text Tidying -> Remove Empty Lines Between Paragraphs command helpful.

Katherine

Nothing has changed in this regard in Scrivener 3 - if you copied in extra space in Scrivener 2 you would have had the same problem. Hopefully Katherine’s suggestion will help though.