compile error

I keep getting this error when I open a specific file in Scrivener. It only happens on this one project, not on any others.

Capture 2.PNG

When the project opens, everything is there and I can work in the project just fine. Since the book is published, I haven’t thought much of it. But now I want to update some links, and when I go to compile a new mobi file, it gives me this.

I have looked online and can’t find a solution for this. It seems like it might be some error from Windows 8.1 updating, but I don’t have a previous version of the project I can access. I’m running a sale later this week, and would really like to be able to update the links in this project so readers can easily find my other books.

The two problems are unrelated. The first indicates an error in the templateinfo.xml file that is used to pre-fill fields in Save As Template; it’s simply there for convenience. Since the file got damaged at some point, you can delete it from the project folder without ill effects, and it will be recreated with the new information if ever you use Save As Template. To do this,

  1. Close the project.
  2. Open Windows Explorer and locate the project’s .scriv folder on your hard drive.
  3. Navigate into the “Settings” sub-folder.
  4. Delete the file called “templateinfo.xml”.

Once you’ve done this, you should be able to reopen the project without seeing the error.

The second error is from the KindleGen compile, but unfortunately there is no specific error shown in the text it spits out. Try compiling to epub rather than mobi, and then opening that epub file in Amazon’s Kindle Previewer. That will run the epub through KindleGen just as compiling to Scrivener does, and it should give you a full log of the results, which may have a little more information. Possibly also this will work where the compile did not, which could suggest a problem working with the epub file from the tmp directory where Scrivener creates it before running it through KindleGen. (I’m assuming that the .mobi file is never created from Scrivener because of this error, but let me know too if that’s not the case.)

Thank you for responding! Your suggestion fixed the first issue without a problem.

I compiled an EPUB file without a problem, and it opened in Kindle Previewer without any errors too. It did mess up the formatting a bit though on a few of the pages. It’s still giving me the same error when I try to compile a MOBI file. When I originally compiled this project, I did it as a mobi without any problems, and I’ve compiled multiple other projects as mobis without any issue this week.

Okay I got the EPUB pretty and working as a MOBI (I had forgotten to check something in the binder which is why the formatting was kooky) but it still won’t compile at least as a MOBI. I would love to figure this problem out, but thank you so much for providing me a workaround for the time being! Now my links will be updated for the sale. :slight_smile:

Glad the workaround fixed it for the immediate purpose. Given that your other projects compile to mobi without issue, it definitely sounds like the trigger is something within the compile settings or project documents themselves. Has anything in the project changed since the last time you successfully compiled it to mobi?

I honestly don’t know for certain–I work on so many projects in scrivener every week–,but I don’t think so. I’ve barely touched it since compiling the first mobi file for publication this January.

If you want to zip up the project and send it to AT literatureandlatte DOT com, we can take a look to try to spot what’s causing the error. You can use File > Back Up > Back Up To… within Scrivener to create the zipped copy, and put a link to the forum thread here in the email.