compile export problem from scrivener to kindle

Hello anyone, Help!!!
I have made a full Draft of a little book (with illustrations) in Scrivener and am trying to Compile in the kindle.mobi mode However only the first 2 pages are exported to my desktop as a file. The first page (which is the cover) reads 39% and the second page reads 100% 9 of 19
I must have pressed something in the draft as when I go back to try again everything is there as it should be, all in order. If there is no solution I have to start again from scratch…??!
Thanks in advance.
Ironbark in Oz

How many pages are you expecting to see?

I assume the cover (illustration?) appears on first page?

What appears on the second page?

Are the illustrations within the draft/manuscript portion of the binder?
Or linked in from elsewhere in the binder or outside the project?

I could be way wrong… but in Compile, you might check these two things…

  • In Compile > Contents, make sure appropriate binder items you want included in the compile have checkmarks in their Include checkbox. If in doubt, put a checkmark in all of them, then whittle those not wanted out sometime later.
  • In Compile > Formatting, make sure that at least one of the levels, probably the bottom/lowest one, has a checkmark in the Text field. Same as before, if in doubt, check them all, remove the unwanted ones sometime later.

Hope that is of some assistance.

One other common problem to check, also in that same Contents compile option pane, is to see if all of the elements you expect to be compiling are in that list. If you don’t see them there, they will not compile. The most common reason for this is that they were never indented into the Draft folder to begin with. If you click on the Draft folder and view it as a Corkboard, you should see all of your top-level items present. If some items need to be indented, just select them in the Binder and hit Ctrl-Cmd-RightArrow to indent them once, then go back to your Corkboard and make sure everything is there and in the right order, then back to compile, and in Contents to verify they now show up in the master list, if all looks well: make a new Mobi.