Compile Font Problems: Chosen font not showing up in compiled doc


I’m not sure if Scrivener isn’t exporting the correct font or if Word is ignoring the font choices I’ve got set but this is driving me crazy.

I’ve set my chapter folders to use Chapter Heading as the section layout and picked a specific font for the headings. When I compile, my chapter headings come out in a different font.

I’ve got no idea what I’m doing wrong.

My Chapter headings are set to use the Heading 1 style. Both Chapter headings and Heading 1 are set to the font I want.

My “folders” are set to section type Chapter Heading.

But my compile comes out with the wrong font…every. time.

Any help is most appreciated.


Did you add Heading 1 in Compile, or was it already there?

If the latter, did you modify it in Compile? If not, it’s Compiling according to the built-in format, not the Editor version of the style.

If you added it in Compile, did you add it after changing the font in the Editor style? If not, same problem as above.

Either way, you can modify the style in Compile or delete it if you want to use the Editor version.

Heading 1 existed in the base format in Scrivener.

All I did in Scrivener was:

  • Change the font face, weight, and size in the style
  • Assign it to Chapter heading in the section layout
  • Make sure all my Chapter titles were assigned the type Chapter heading

In Word, I did nothing. That’s how it comes out of compile: As Times New Roman not as Open Sans as specified in Scrivener.

When you changed it “in the style”, do you mean you redefined the style in the Editor? If so, and if the style was already in the styles list in Compile, the built-in compile style (which is Times New Roman, of course, since your format is based on TNR) overrides the Editor version.

If that’s the problem, do what I said before: delete or modify the compile version.

In the very first screenshot we see that the Override checkbox is not checked. If you want the styling preview you see there to have command of the matter, you need to check that box, right?

Also, I am confused that your Chapter Heading layout in the upper pane there is set not to include any data from docs assigned to it (not the title, not the text, not anything).

If by “in the Editor” you mean in the pane labeled “Styles” in this screenshot

then yes, I “redefined” the style by changing the font family and weight.

This format is already a copy of an existing Scrivener format. How will deleting something that’s been customized help?

If customizations in the Styles pane are overwritten by the format the customized version was copied from, why bother having the ability to copy, save-as, and customize a format at all?

The override checkbox seems to have no effect. It comes out Times New Roman whether that box is checked or unchecked.

I’m just having the Chapter Heading auto number the chapters. If there’s a way to get folder names in there, I’d love to know.

I can’t post images as I am a new user.

In your first post, you have an image under:

It says:
Compile for Microsoft Word
Sections Layouts
Font Times New Roman

That last line is causing the issue. Select the modal and change it to the default setting.



That absolutely worked! Thank you!

That’s Compile, not the Editor, and it’s not what I’d usually call the Styles Pane (which is in the Editor). But it is a styles pane, of course.

I was talking about the scenario where the Editor version is the one you want. If the Compile version is the one you want, that’s a different situation.

That’s a compile style, not format. These are compile formats, on the left where it says Formats at the top:

Just the opposite, and the language is scrambled.

Compile styles override Editor styles (when they have the same name).

It has no effect for headings coming from Prefix, Suffix, or the Titles checkbox. It affects text, which isn’t there since you didn’t check the box to include it.

Check the previous screenshot, where I included <$w> for chapter numbers, <$title> for titles, and more.

(In the OP’s third screenshot.) Good catch, @SWM !

That setting overrides styles, apparently … which I did not expect at all.

Yes, that was a good catch. Wish I’d thought of it!! That is a(n otherwise very) handy universal font override.

If you want to use folder or file names as titles or subtitles for parts, chapters, or sections, select the title option for the relevant section layouts.

So if you are using chapter heading as a section layout for your chapters, you just need to tick the title checkbox.

I would add an image here, but the forum won’t let me as a newbie. But from the first image in your first post:

  1. Sections Layouts
  2. Chapter Heading
  3. Tick in the Title column

As your folders already have hierarchical names, such as Chapter 1, compile will produce Chapter 1 from the settings in title options and then repeat Chapter 1 from the folder name.

However, if you rename the folder to Expansions, for example, compile will produce Chapter 1 from the settings in title options and Expansions from the folder name:

Chapter 1
~ Expansions ~

The styling and layout options are limitless.


Doing that gets me back to where I was, only the titles come out in Courier instead of Times New Roman unless I assign the section title to the Heading 1 style from the compile styles pane. :flushed:

There’s a lot of interesting interaction here among the Section Layouts pane, placeholders, the Compile Styles Pane, and the containing folders and how they’ve been assigned to semantic structures.

What I’ve done to get where I want is styled Heading 1 the way I want - Open Sans, Light, 18pt - in the compile styles pane

Assigned Heading 1 to Chapter Heading in the Section Layout pane

Used the <$levelN_title> placeholder slug in the title options for Chapter Heading (and also formatted that to Small Caps)

Assigned Chapter Heading to all of my containers in the compile pane

A million paths to the same result :slight_smile:

Thanks for the help!

In the image below the sentence that says “Assigned Heading 1 to Chapter Heading in the Section Layout”, the tick box for Chapter Heading → Title in not enabled. If you tick it and compile, what happens? Without being selected, the folder / file names won’t be included.


You don’t need the tick box for Title beside chapter heading if you’re using a placeholder in the Title Prefix section.


Does the same as ticking the box :wink:

1 Like

They will if their placeholders are included in Title Options.

1 Like

Thanks, both. Hadn’t seen the image properly. My error. Apologies.