Compile for ebook .mobi changes 2nd paragraph style when using "as is" formatting

Problem: 2nd paragraph in each Kindle .mobi section is missing its indent as per defined style in Scrivener doc

I am trying to compile a 92,000 word novel using Scrivener 3.1.3 (11945) for ebook .mobi in Mac OS Mojave 10.14.6. KindleGen_Mac_i386_v2_9.

In Compile, I’m using default section layouts as is, as it appears in editor.

In my editor, each section begins with an unindented paragraph and uses a style sheet specifically intended for the first paragraph in each section. Subsequent paragraphs are styled with the same body copy except they all have an indent.

After compile, I review in Kindle Previewer 3. Unfortunately the second paragraph, which should have an indent (and does in Scrivener editor) does not have an indent in the Kindle Previewer. So somehow the second paragraph in each section has lost its style. Subsequent paragraphs in the .mobi do have the indent.

This is what I have done to troubleshoot with no luck—the second paragraph still appears in Kindle Previewer without the indent

  1. in the Scrivener doc, I’ve redefined styles for Body Copy in first paragraph with no indent and also Body Copy style for subsequent paragraphs with the indent and applied these new styles to all the paragraphs
  2. I deleted the Scrivener .plist
    3)I copied two or three sections to a new Scrivener document

I also downloaded a fresh copy of KindleGen, deleted the old Body Copy style sheet, created a new style with the first-line indent and applied it to all but the first paragraph in each chapter. But the problem remains: the second paragraph in all chapters lacks the first-line indent in the .mobi while all subsequent body copy paragraphs are correctly indented.

By creating your own “Body Style” you are setting yourself up for all kinds of problems. With Scrivener (as opposed to Word or equivalent word-processor) you should set what will become “Body text” or “Normal” in the Preferences > Format pane, with the first line indent, and make all your text “No Style”.
For the paragraphs following headings, you can tick a box in the compiler to do that automatically for you, or set up a “No-indent” style for those paragraphs, making it a paragraph style only. If you untick “include font family” and “include font size”, it will allow you flexibility with fonts as it will use your default font and size from “No Style” which means you can edit in whatever font and size suits you and change it to the font you want in your compiled document through a simple setting in the Compile dialog.

Hope that helps.

Mark

This is the 8th book I have compiled using Scrivener. Up to now, I have had no problems using styles in Scrivener and then compiling them for .mobi. This is the first time the compiler is not working for me