Compile for PDF....trouble with settings Pt. 1

Please bear with me for yet another compile question…sigh…

NOTE: I’ve broken this up into more than one message as I could only attach 3 images at a time. Bear with me.

I have, with the help of the Scrivener tech team, figured out the last issue I had (which in the end turned out to be a bug).

Note: I have included some screenshots to help you see what I am doing.

I am now trying to format the same MS into a PDF. It is a collection of short stories and bonus chapters, which I have organized into Part One: Short Stories and Part Two: Bonus Chapters. Under each of these sections there are a cascading set of folders which are then subdivided into chapters, scenes, etc. (image 1).

Image 2 and 3 are the result of compile. You will see that for some reason, “Chapter One” is at the end of the Part One page. Note that Chapter One is also in Uppercase. When I look at the compile windows and the section layout, this does not appear in the Chapter Heading layout image. It has everything as it should be, but without Chapter One at the end.
Image 3 is showing the next part, which is actually Chapter One, but is now displaying Chapter Two. Note that Chapter Two is, in the MS, actually Chapter One.

What I want to have happen is to have the Part One page, with the image and the Title “Short Stories” below, then the next page should be a separate page with Rare, Prized and Feared (the name of the story), and then the next page should start with Chapter One and the scenes following. NOTE: Chapter Nine, inexplicably, is formatted like this. The PDF shows “Chapter Nine” on a separate page all by itself, then the next page starts with Chapter Ten.

(more explanation and images in next post)

Before I delve in to what the compile issues seems to be, a bit about forum usage:

If you just replied to your initial post in this thread, the images could have been added to that reply. As you’ve done it, there is no link between pt. 1 and pt. 2 discussion threads.

As for your compile settings… another image that would be helpful is a look at the right-side pane of the compile window, showing which section types were assigned to the first several folders/documents.

Are you familiar with how Scrivener can automatically assign section types to files and folders? Do you know how to change that behavior?

I think a lot of confusion may come from the fact that a layout you’ve chosen for folders that are 3 levels down from “Manuscript” includes adding in “CHAPTER XXXXX” where XXXXX is an automatically incrementing number, printed out as an all-caps word… so ONE, TWO, THREE, etc… while you are also typing in “Chapter 1”, “Chapter 2”, etc… in the binder, and including binder titles in your output. I’m not quite sure where “Chapter Two” is coming from, but I think seeing how the section types are being assigned may shed some light.

Ah yes, sorry about that. I didn’t think about just replying to my own post. I have done compiling before, and I do have a basic understanding of how it works…however perhaps not as basic as it should be. :unamused:

Are you using Binder titles as titles in the output or using the built-in function in Compile to create ’Chapter #’ titles?

I’m using the Binder titles as titles for output.

Compile can create Chapter prefix, dynamically, the way you want, so you don’t need to use the Binder titles if you only want the word ’chapter’and a number.

… and to follow on that, it appears to me that the combination of section types that are assigned to each of the folders in your manuscript, the section layouts that are assigned to those, and the binder titles is what’s causing the various, confusing set of “chapter X” to appear in your compiled output.

Consider temporarily changing the folder names for Chapter 1, 2, 3 and maybe through 5 or 6 to other words entirely (ex: change “Chapter 1” to the title of that short story), then compile. You may then begin to see where those titles fall in relation to the words “CHAPTER ONE” and so-forth.

Ok, thank you @rdale, I’ll try that