Compile for print cutting off last few pages

In the past few months, I have printed off several sections of my manuscript to do some editing, and both times I noticed there was content missing from the end. The first time, I assumed it was that I hadn’t selected the last section or two that I needed. This week, though, it cut off a few pages from the final section. Today, in an entirely different project, I tried to print one single section of straight text–no images or anything inserted other than a couple of comments (which I later deleted and tried again when I saw that suggestion–no dice). Both times, it cut off around the same place, but the 2nd time, I set the spacing to 2.0 and somehow squeezed an extra line out of it. I have tried several solutions in several old related threads on these forums, but I cannot figure out what is causing this. Any ideas?

Since it is just a single section, Scrivener did allow me to simple print it without compiling (which I didn’t think to check initially because previously with multiple sections, it had not been possible), so I used Print Preview to ensure everything was visible and printed that way–That time it printed properly.

Compile to print is problematic. (As in: it doesn’t work half of the time.)
I stopped using it long ago, and exactly because of that : content missing from the printed pages.

The workaround is to compile to PDF or RTF with the compiler set to Open compiled document in default application, and print from that.

Snapshot

I have a folder on my desktop which i named “to print”.
I point to that folder as my compiled file destination and, having the compiler set to auto-open that file afterwards, I name my output file a very sophisticated “fkjdsfl;sdk;lsd;lkdf” (intentionally random fingers’ crawl on my keyboard). ← The point being that the file’s name don’t matter at all.
Then print.
Every now and then delete the “to print” folder content so that you don’t uselessly accumulate.

P.S. My computer’s default is set to open PDF in Chrome; RTF in LibreOffice.


Printing from the file menu works 100%, but you don’t of course get any of the compiler’s functions.

1 Like

Thank you! That’s helpful information. I’d gone back to attempt it as a PDF when I realized the basic print function was available, so when that worked, I didn’t pursue it further. Good to know that seems reliable, though! I’ll do that next time I need to handle multiple sections at once. Thanks!

1 Like