Compile Formatting of Hierarchies

I’m having a frustrating time with Compile and wonder if someone can help, please.

I have a document that has five levels of hierarchy, as follows:

Parts
Chapters

  • Subheadings
      • Sub-subheadings (sorry, can’t think of a better name for them!)

I want to have different formatting for the titles of each (plus a hierarchical numbering scheme), so I go to the Compile pane, the Formatting option, and start adding Section Types. All good so far.

First issue: There are two Level 1/1+ Section Types. And when I click on each Section Type this is what is highlighted in the binder:

First Level 1 - Nothing is highlighted
First Level 2 - Parts are highlighted
First Level 3 - Chapters are highlighted
First Level 4 - Subheadings (but only those WITH sub-subheadings) are highlighted
First Level 5 - Nothing is highlighted

Second Level 1+ - Subheadings (but only those WITHOUT sub-subheadings) are highlighted AND all sub-subheadings are highlighted

I cannot delete the Second Level 1, so there seems to be no way to set up formatting for headings where subheadings and sub-subheadings have different formatting. I’ve not started to look at hierarchical numbering yet.

Am I missing something obvious? (There are no as-is options ticked, and I have no Compile Group Options checked).

Thanks in advance for any help.

You describe the levels of organization in your text. This organization must be matched in the binder. at that point you can set up the titles of each part, chapter, section etc as you wish.

In the Formatting pane of the Compile dialogue, you will find that you can select various levels. In the menubar of that pane, just to the right of the Options button, there is another button marked, cryptically enough, ± and it is this button you want to select to make the changes you desire.

Say you have Parts as folders that enclose Chapters which are also folders. in the Formatting main pane you will see that folders are listed as Level1+ so you select that icon for the Level 1+ folders and then click on the ± button. This then creates a Level 2 for folders beneath the Level 1. (And if you have sections as folders, then that level will be marked Level 2+ and you can select it and click the ± button and create a Level 3.)

Continuing in this vein, and playing around, you should be able to achieve the results you want.

  • asotir

If I am reading you correctly this resembles a problem I had too, and I must say that the solution was not obvious. I had only three hierarchical levels so:

Chapter heading (1.)
Subheading (1.1)
Sub-sub heading (1.1.1)

Now, scrivener seems to work with three “different” types of documents (even though they “are” the same - i.e a canvas where you write text). I am most likely describing things with the wrong terminology here, but what I mean with this is that in my binder I use the blue folders as documents equal to level one (chapter heading), the container documents for those of level two (subheading) and the “single” documents as level three (sub-subheading). Within the compile settings I had to specify the tree levels for each “type of document”.

Possibly my attached screen shot can help you. Otherwise maybe the thread I started (that helped my solve it) may also help you: https://forum.literatureandlatte.com/t/levels-and-titles/24529/7

I’m not sure if this will work, but using the above screenshot as an example, there is one method you might try: Add a document under your sub-heading documents that lack any sub-sub-heading documents, like “The Road Ahead” and “Territorial Reconfiguration and new Regionalism”. Then un-check the “Include in Compile” checkbox in the inspector or the Contents pane of the Compile window.

In theory, this will change the sub-heading document icons to the stack-of-papers icon, making them match with the corresponding level of the Formatting pane in Compile, but won’t create a new sub-sub-heading in the compiled output.

Thanks very much for all this assistance, folks. I appreciate the information and guidance

It was bircovic who gave me what I needed. Because you can change the icons in the binder, they don’t reflect the icons in the Compile settings and that had confused me much! (The difference between documents, stacks of paper and folders…) The L&L video on the topic, linked in the thread that bircovic points to, helped a lot too, and I was able to make good progress sorting this out. I was relying on the Scrivener manual but I should also have looked for videos on the topic.

The numbering is working now, but I need to figure out how to suppress numbering for some sections, start numbering from a point, etc. Scrivener is great software, and very powerful, so I’m confident that I can achieve what I need to do. Otherwise, I’ll be back here looking for help!

Thanks again, everyone.