Compile Formatting Off

Hello,

Apologies if this has been discussed but I can’t find any info on it.

I have a script that I updated from Scrivener 2 into Scrivener 3. It’s my first time revising this script in a year or so. The problem I have is when I compile a pdf, the script LONGER. It went from 101 pages to 103 even though I’ve made no additional writing.

If I go page by page (side by side) of my PDF and the script in Scrivener - the PDF spacing is off. The first two pages are fine as I scroll, but the last sentence on page 3 of my pdf has now moved to Page 4. It’s a minor difference yet it doesn’t match the actual script in Scrivener. Whereas all my prior PDF’s I compiled from before updating to Scrivener 3 always matched page for page, line by line.

I don’t know how to fix this…

Added side by side. You’ll see that the PDF doesn’t match the page in Scrivener.

The last character and dialogue from the Scrivener page are moved to the following page on the PDF.


Hi,

This is improved behaviour in Scrivener 3, which now supports widow and orphan control, something earlier versions did not. (It also supports MORE/CONT’D for scripts). So, in your Scrivener 2 print-out, you can see that there is a “widow” at the end of the page - a single line from a paragraph left behind. Standard screenplay formatting requires such lines to be moved down, along with any character tags, which now happens in Scrivener 3.

You can change this behaviour if you want (by duplicating the “Screenplay” Compile format, editing it and turning off widow/orphan control and the option to fix screenplay elements that flow across pages). However, as I say, the new behaviour is the accepted standard for screenplay formatting.

All the best,
Keith

Hey Keith,

Wow, that was super helpful, and I agree that makes it better. Is there an option to change it in Scrivener so that my screenplay reflects that formatting as I write? Or is it only a filter added once compiled for export?

Thank you.