Compile > Formatting Options Missing

Hello,

I’m trying to compile a Kindle eBook (.mobi) and want to preserve the alignment of certain parts. The various online guides have said I need to go into Formatting in the Compile screen and click Options to get the Text Formatting Override Options. However, when I do I only get two options:

  1. Insert subtitles between text elements
  2. Place notes after main text

i.e. I am not getting the full list of options, including the Text Formatting Override Options.

I am using Windows, Scrivener version 1.9.7.0

Could anybody help me, and explain why I’m not seeing the full range of formatting options?

Many thanks!

Hello TB. You have clicked on the little blue arrow on the compile pane to open all the options?

Hi Argoed,

Yes, I have. I’m wondering whether there are fewer options in the Windows version. Can anyone else with Windows Scrivener access the full list of options?

The options vary according to the output format you have chosen, so it’s possible that some you are looking for are available for say PDF, but not for Kindle. I’d expect the formatting options to be available though.

Hang on while I boot up Windows in Parallels and check…

Here we go:

This is a screenshot of the Formatting Pane for the E-Book compilation pre-set.

It looks like you’ve been clicking the Options button – that’s actually used for something else. Instead, you need (or you have the opportunity to – it’s often not necessary) to set the formatting options in the dummy text box below the list of Levels.

To change the formatting of a section – say all scenes – highlight that section (in this case it’s the Level 1+ text section (the icon of a single page)). If you want the scene to have a title, check that box (in the picture we don’t). Make sure the Text box is ticked. Then make your formatting changes using the dummy text box below. Eg to turn it all italic, click in the dummy text and then the ‘I’ button in the formatting bar – just as you would in the Default Formatting options for the Editor.

Be aware: this changes the format for ALL the documents of that particular type (Chapter, Scene etc) – you can’t reformat individual scenes using Compile. If you want to say format Chapter 3 differently from other Chapters, then change the formatting for the document in the Editor to make it look exactly as you’d like it in the final output, then in the Inspector under General Meta-Data, tick ‘Compile As Is’.

BTW, if you haven’t already done so, you really should do the interactive tutorial (on the Help menu), because it runs through the basic elements of Scrivener, include Compilation and As-Is, and that will make things look a lot clearer.

Hi brookter,

Many thanks for your reply, and the effort you’ve put in.

When you say:

Unfortunately, it seems that something else is what I’m trying to do, i.e. preserve the alignment of anything in the original text that is centrally aligned. When you read this guide here (from a Mac), you see the following options:

But I don’t get these, I only get:

My guess is these options are not available on the Windows version, which if true represents quite a difference in functionality between the two.

Many thanks for your help!

Hi - sorry for the misunderstanding. I suspect you’re right and that’s a Mac only setting for the time being.

In that case, you could possibly fake it by having a separate document for each element of centered text, set to ‘Compile As Is’ – you’d have to be creative with Separators (ie use a mixture of Documents and Document Groups at a certain level) to make sure the transition between paragraphs looks right. But it would be fiddly to do.

As another data point, I’ve just done a side-by-side comparison of the Mac and Windows versions and I’m not seeing that same extended range of formatting options in Windows, so it does look like it’s currently Mac-only.

Thanks brookter and devinganger!