Compile freezes

Dear Team,

I have been a happy Scrivener user for a couple of weeks now as it greatly supports my PhD work. Had I discovered this great tool earlier, it would have saved me a lot of time, I guess. Never experienced problems so far.

Today was the first time I needed to export a raw draft version for print.
(I had done this with the tutorial draft before, and there it worked fine.)
I hit compile, chose the documents I wanted to be included and selected Print. The progress bar behaved regularly filling up from left to right, but once it reached the right corner it changed into a slowly moving white and blue striped one, and this remained infinitely. Even waiting for half an hour it did not disappear. Hitting Cancel and reopening the Compile window just produced the same window with the banded progress bar again. And no file was produced whatsoever. The only way to stop this is closing Scrivener and reopening it.

After having reproduced this behaviour for several times, I have been trying several things until now, but none of them helped:

  • Chosen PDF instead of Print in the Compile window.
  • Checked all project files one by one for any corrupt ones (none found).
  • Repaired disk permissions.
  • Reinstalled Scrivener 2.X.
  • Installed the Scriv211beta-020911 over it.

I’m on a MacBook Pro 15’’-Intel Core 2 Duo-2,8 GHz-8GB RAM running Mac OS X 10.7.1 and
at my wit’s end - any help appreciated.

Thanks
Harald

Hi Harald,

This sounds like a bug. Would it be possible for you to zip up and send me your project, to kb-tech-support AT literatureandlatte DOT com?

Many thanks and all the best,
Keith

Hi Keith,
even the zipped file is 37 MB, so I have uploaded it for you.
Link is in your email.
Sorry to bother you with this.
Thank you so much and best wishes
Harald

Hi Harald,

Thanks for sending the project. I’ve found the cause and fixed it for 2.1.1, and I’ve also sent you an e-mail explaining how to get back up and running again - the cause is a blank footnote in the project, and a bug in Scrivener means that it is currently choking on blank footnotes. Thus you just need to remove that empty footnote to get Compile working again (I’ve given the exact location of the problem footnote in my email).

Thanks and all the best,
Keith

Hello Keith,
thank you for this amazing customer care! And, of course, it works now. Actually, one should never have empty footnotes, but as I am translating some paragraphs from German into English, this can easily happen when swiftly cutting the footnote out - accidentally leaving a final or initial space - and pasting them into the translated paragraph.
Very best wishes
Harald