Compile Hanging when exporting to mobi

When I try to export to mobi format the compile starts and then just sits there. When I cancel and go back into compile it looks like it’s still trying to work.

I’m using version 2.3.1 for Mountain Lion.

Any suggestions? Thanks


Might be to do with ML’s security settings. This link explains: … -scrivener



Thanks Mac

Tried that but it didn’t work.

It seems (very oddly) to not export just one project to mobi…tried some others and it works with those. Not a big project either. Tried dragging the files to a new project but still wouldn’t compile for mobi. Odd!

How strange. Sounds as though there is something in one of the files that is in some way corrupt.

If you drag just one file to a new project and export, will one file work? If it does, you could add files and try compiles after each addition—hopefully identifying if one of the files really does have an error.

Of course, if the first file fails, at least try a second file in a separate new project to establish if the first file is really problematical or not.

Alternatively, rather than dragging the files, can you copy and paste the text to a new project to see if that works?

Maybe someone else will come up with a better idea.

Do other compile formats work with that project?

Good luck