Compile ignoring a specifc format

Hey,

I’d appreciate a little help.

I’ve recreated and tested one compile format, but I got stuck.

In the image below, the yellow part should be compiled as a direct citation (4cm to the right, font size 10, etc.). I’ve created a special style to make it easier to see them in the flow and jump between them easily.

The point is that compile can’t recognise it as such unless I put empty lines around it (the plus sign is there to make it easier to see the lines). Without the lines, it will compile everything as one long paragraph.

In the compile, I’ve enabled the Override text and notes formatting, but this should not matter since when I put the lines, it works, but otherwise, it doesn’t. I really can’t see what I’m missing.

P.S. The blue and red parts are the Zotero + Scrivener + Odt file integration; if anyone has a better solution to work with Zotero and is kind enough to share, or point me to other posts, I’d love that.

Is that style currently formatted as you want it to compile?
If not : did you add it to your compile format, and format it there ?

If your issue is that it compiles as it currently looks in the editor, then I already know the answer to the above questions. Act upon the second one.

3 Likes

Are you aware that there is a built in “block quote” you can use for this?

If for some reason that doesn’t work for you, I second Vincent_Vincent’s advice.

2 Likes

Hey, thanks for the prompt replies!

No, it should look like this.

Yes, I did add it to my compile format and formatted it there.

I thought I had messed up with my compile format, so I did another test.

  1. I got a new binder item, scribbled something in it, and used the “block quote” option mentioned above.
  2. I duplicated the Default format, added the “block quote” to the list of Styles, and formatted it how I wanted it to look (like in the image above).
  3. If I run the test without the empty lines around the text in the “block quote”, it will ignore the quote and treat everything as if it were a single paragraph. But if I add the empty lines around this part of the text, it will format correctly. One paragraph, then a long quote and finally, a new paragraph below it.

Here’s the text in scrivener

and here the result in word.

Zip up a small project which shows the problem, together with your compile format so that we can have a look at it and see what’s going on.

You’re not set to compile to a markdown format or epub are you?

:slight_smile:
Mark

2 Likes

Mark, you have nailed it!

In the compiling window, under Options, I had the “Convert Mardown…” and “Convert MultiMardown…” options marked. I guess I was trying to understand Markdown better and must have enabled them and forgot to turn them off afterwards. And it was doing precisely what the manual says it should. That is so stupid! I have to say, I still struggle with the complexity of options and settings in Scrivener, I had better stop fiddling around, or at least not do it with important projects.

With the options disabled, everything is as it should be. One thing I don’t understand is that with the options enabled, the compiled document would ignore some footnotes and not compile them at all, but not all of them.

Thank you once more!

Felipe

2 Likes