Compile in Scriv 3 - some text reverting to "as is"

I’ve also fallen down the Compile rabbit-hole and have been going in circles reading posts on the forum and sifting through the manual and watching the tutorials. But I can’t figure out what seems a very simple problem.

I imported my Scriv2 Compile Format, the only format I’ve ever used to compile. All looks correct, with my Chapter pages showing “CHAPTER ONE” and the Chapter title, with the scene text beginning below all correctly.

But randomly, one and a half specific scenes in my current manuscript are reverting to “as is” text – that is, the font and font size that is in the Editor – whenever I compile. No matter what I try to change, this one chapter and half of the next chapter compile with font and font size identical to what I use in the editor – not the 12 pt. Times New Roman that the rest of the manuscript compiles in.

Why on earth would it do this? Am I missing some obvious setting that would randomly select one chapter and only half of the next to keep the text “as is”?

Any help would be gratefully received!

P.S. As it turns out, when I use the Scrivener Manuscript Format (Times), it turns all text, excluding Chapter Titles, into the text I have in the editor (Baskerville 18). I’m certain there’s a simple reason it’s doing this. Is there some setting that reverts compiled text to the editor’s active “style”?

Adding to my confusion is the fact that the text in the “Section Layout” part of the Compile window is the correct text – 12 pt Times. So I can’t understand why it’s keeping the editor’s formatting!
Screen Shot 2017-11-27 at 7.27.56 pm.png

Preserve Formatting block?

Slightly misnamed Style? (Because it’s misnamed, it looks like everything else, but isn’t quite,)


Hi Katherine,

Sorry, you’ll need to be more specific as I seem to be missing the obvious.

How can a Style be misnamed? And where would it be misnamed, if this is indeed a problem?

As for Preserve Formatting, I don’t have this ticked under the Format menu – is that what you mean?


By a misnamed style, I mean something like most of your text being styled as, say, BodyText, but there was a typo that inadvertently created a BidyTect style in the problem areas. Redefining BodyText in the Compiler won’t change what happens to BidyTect.

I’d also check and make sure the correct Section Layout is applied to the problem items.


I think the root problem is that I just absolutely cannot wrap my head around the new Compile. I have the correct Section Layouts, and the text looks correct, but I’ve actually figured out the problem.

When you mentioned Styles, I looked at my Editor – and as I always did in Scriv2, I like to write my scenes in 18 pt Baskerville, and I’ve always saved this Style as “Scene,” as that’s the font I use typing scenes in the Editor.

What I somehow missed is that I needed to click Edit Format in Compile down on the left, having created a “Style” that’s 12 pt Times New Roman, and then select that as the “Style” for compiling.

This feels needlessly complicated, and I don’t recall having to do this in Scriv2. I seem to remember simply opening the compile settings (under Preferences perhaps) and selecting the text in each of the Section Layouts, and setting it to the font and size I wanted in that window. That made more sense to me, so I guess I was not looking for a labeled style in order to get the typical 12 pt Times New Roman – especially using the “Manuscript (Times)” pre-set format,

Regardless, thanks for mentioning styles because that would not have occurred to me, as clueless as that perhaps sounds…

Well, styles didn’t exist in Scrivener 2, so it was impossible to use the “wrong” one. You may have had a formatting preset called “Scene,” but it was just formatting. It didn’t apply a label saying “This text uses the Scene formatting Style.” That’s what true styles do in programs like Word, and in Scrivener 3.

There’s no requirement that you use styles in Scrivener 3. You can just assign 18 pt Baskerville as the default format for the project and proceed as you always have.

But if you do choose to use Styles then yes, if you want to change what the Scene style looks like in your output document, you need to edit the Compile format to do so.


Okay, thanks, I think I’ve got it now, at least enough to get by.

I can’t remember what it was called in Scriv2 then if it wasn’t “styles,” but it was in the same place as it is now, above the editor on the top left, where you could choose formatting for the editor window and save presets.

I’ll play with the default formatting. I feel like I had some weird combination of things happening because, as I said, only certain parts of the text were in Baskerville, and the rest were in Times. I can’t even seem to replicate it now that I’ve set the style in Compile, so I’m at a loss. In any case, thanks for steering me in the right direction.

Oh, I know exactly what feature you meant. “The thingy that styled text” in Scrivener 2 created presets that you could use to apply several formatting changes at once – font, font size, color, etc. – but it didn’t label the text as being BodyText or Header1 or whatever.

In Scrivener 3, the tool is in the same place and superficially works in the same way, but it’s quite a bit more powerful. In Scrivener 2, for example, to change formatting you had to manually select any text associated with a given preset, and then change it. Good luck finding every block quote in a 200 page book. In Scrivener 3, you can change the BlockQuote style in one place, and you’re done. Moreover, and this is why many users requested the feature, you can ship your manuscript off to your Word-based editor with neatly labeled Headers and Body Text and so on, ready for automatic processing by his layout tools. More about the new Style system here: … th-style-s

As you discovered, Styles are persistent unless specifically overridden at the Compile stage. Which is very useful in most situations, but can cause unexpected behavior if you aren’t prepared for it.