Compile is driving me nuts: font size

Good morning!

I am trying to compile my draft for proofreading. I select “Compile”, “PDF”, select for example “Modern”, duplicate the Format. In the format I change the font and size of my “scene”.

When I compile, the font is changed, but the size stays the same.

What am I doing wrong?

Thanks for help…

Wolfgang

Some simple sanity checks:

  • When you go to edit the Format, are you double-clicking on the preview tile itself that is assigned to “scene” in the middle column? If not, are you making sure to check below the section layout listing, to ensure what you are changing is actually assigned to scenes? One simple mistake we’re checking for here is editing the wrong Layout.
  • Do you use styles for your body text? If so, you’ll have to perform additional configuration steps whenever you create a new compile format (one reason we suggest not doing so in the editor). Make sure to add this style in the Styles compile format pane, and adjust what body text should look like here, too (and note the checkboxes at the bottom to enforce font size/family changes).

Also must make sure SAVE the edited format BEFORE compiling, so changes are saved. Suggest giving it a modified name like font size.
If did right, close format after made changes and open again and look at section layout for scenes and see in format window below if font size remains changed to new value.

Thanks for reply!

(I can not upload screenshots, so:)

I changed the scene - font to 48 point Rockwell, which is displaed in the preview pane. Output is around 14 point Avenir Next.

I have changed each and every setting, no change.
I strongly believe I make a very dumb error, but I cannnot figure it out!

W:

You should be able to upload now. What is most efficient is uploading a sample project with your settings and everything all there, rather than rooting through half a dozen screenshots.

Just create a new Blank project with a dummy paragraph set the way you have it in the main project, then edit your Format so that it is saved to “My Formats” so that both projects can use it, assign the layouts, give it a test, and if it still doesn’t work use File ▸ Back Up ▸ Back Up To... with the zip option enabled, and upload that.

You might find in retracing your steps what is going wrong, too!

Also if it is easier for you, and the main project isn’t huge, feel free to send it to me in a private message, or to technical support, with a note in the ticket referencing this thread URL.

Hello, AmberV!

Thanks for helping. I created a new project, set my editor to my Font and size, compiled with other font and size - PDF is in Editor font.

NotWorking.zip (307.0 KB)

Thanks again.

W:

Okay, it is as I suspected above, it is this problem:

You have a body text style called “Text” in the editor, which is setting all formatting including font family and size. That is your tool for telling the compiler to ignore this text when changing formatting—and it is dutifully doing so. Your two main choices are:

  1. As above, edit your compile format, go into the Styles pane, and add this “Text” style, changing its formatting here. This is how you can make a block quote look completely different if you need, for example in Courier manuscript. All Scrivener looks for are matching names. If there is a style in this list that uses the same name of a style in your project, then it will change how it looks given the settings here.
  2. OR: Get rid of the “Text” style in the original text. You don’t really need it, since the compiler can update the formatting freely at that point, and secondarily you can have the compiler assign a style instead of just changing the formatting, if your workflow beyond Scrivener requires this “Text” style. So to do that:
    1. You might want to first make a backup copy of your main project, using the same command you used to create a zipped copy, since this is a radical change.

    2. Use the Format ▸ Style ▸ Delete Style ▸ Text menu command.

      So at this point it should be working fine, if you do a test compile.


      If you do want styled body text though, then continue with this checklist. Obviously, if you are compiling to PDF only then none of the below matters. PDFs don’t have styles, this is for continuing your work in a word processor.

    3. Open the Compiler and edit the Format.

    4. First go into the Section Layouts pane, and for “Abschnittstext”, put the cursor into the sample text and use the Format ▸ Copy Formatting menu command.

    5. Switch over to the Styles pane, click the + button and add a new generic Paragraph+Character style, calling it “Text”.

    6. Click into the sample area and use the Format menu to paste formatting.

    7. Switch back to the section layout, click into the sample text, and now pick from the Format Bar the “Text” style you just created.

      All right, now when you compile it will look the same as at step 2, but in Word or whatever word processor you use, the text will actually be styled as you require.

Here is a copy of your sample project adjusted to demonstrate the full second method.

NowItWorks.zip (46.1 KB)

Thanks a lot.

I thought I NEEDED a format to get every new text with my preferred font & size in the editor. While testing I found in project setting/formatting the checkbox to set font and style for new texts.

So I removed the style, and now I am fine!

Thanks for help!

W:

Great! Glad that works for you as it is the simplest option, and very much aligned with the software design.

It is one area where Scrivener is a bit odd, compared to word processors. Styles were made so they could be 100% optional rather than something everyone has to learn how to use and apply to their work. The easiest way to use the program is to just open it up and write normally, with whatever font you like to use while writing (which as you note, you can set in your defaults). Styles become something you can use here and there to force text to be different.

Styles can be used as you have been, but as you can see from the checklist above, it makes everything more complicated and requires more fundamental knowledge of the software. It’s there for those that need it, but it’s a pickier way of working. You have to remember to set up your compile Formats more completely every time, and so on.

In my experience, compiling always saves the format.