compile is incomplete

I am both new to Mac as well as to Scrivener and trying to compile and getting only a fraction of the manuscript coming through. Can you help?

Hello, Amma, and welcome to the forum!

I suggest you to try this:

  1. Select the Draft (or Manuscript) folder on the binder by clicking on it
  2. Select Compile.
  3. On the Format as combo box, select Original.

Make sure that all documents you want printed have the Include in compile check-box applied.
Go ahead with the compile.

Does this help?

Otherwise, I suggest you to go through the tutorial (again, if you already have). Scrivener compile feature is very powerful but the default settings work in such a way that they don’t change anything on your document as you typed it.

After some fiddling as well as mishaps, I have figured out the problem- it was a level problem- the sections weren’t showing up in compile.

I’m having a similar problem – apart from revisiting the tutorial, I’ve tried what’s been suggested here, but the compile feature still seems to freeze at about page 19 of a 52 page document. Anything else I could try?

(ETA: while I wouldn’t say I’m a Scrivener expert, I’ve been using it for a couple of years and am, as far as I know, doing exactly the same things I always do to compile and export my work to .doc format. There seems to be something wrong with this particular file – everything else compiles and exports as normal – but I don’t quite know where to begin.)

This can happen if there is some kind of data corruption in one of the component files. Large images can also make Compile take a long time, or even freeze altogether if you exceed the file size that your computer can handle.

One way to begin identifying the problem is to do partial compiles, splitting the original into sub-documents as necessary. Once you find which specific part of the project won’t compile, you can examine it more closely to figure out what’s going on.


Thanks, Katherine—a methodical, section-by-section approach revealed that one set of comments was the culprit. Deleting and reinserting them worked. Appreciate the quick reply!