Compile MMD

If I compile the document to MultiMarkDown, there is no export of any format except the headings (which are the titles of the map - and textfiles). There are no quotes ( > ), there is no bold ( ** ), there are no italics ( * ), there are no lists ( - ) or ( 1. ). There are footnotes (if I use them). But now I have to style the fresh MMD-file all over. (also I have to correct the headers if necessary ( # ) into ( ## ) ).

I presume it has something to do with the compile settings. Somebody with some good ideas? I would really appreciate it.

I’m not sure what could have gone wrong. Are you using Mac or Windows version? (I use the Mac.) I’ve experienced simple and flawless export to MMD.

In the compile options for MMD there are 5 export options. I use the MMD only (not MMD to HTML or other ones). Is that what you are doing?

And, just to be safe, you have written your files within Scrivener in markdown or MMD? (It won’t convert regular text to MMD). Sorry if this seems like a silly question, just double-checking here.

Thank you for your answer. I am still looking for the best solution to write my stuff. I am using the Mac version. In Scrivener I write the same way I would do in Word or Pages.

I write for the web only. So I use everything MMD has to offer. Quotes and also footnotes.

I use Marked to convert MMD to HTML, because the HTML output of Scrivener seems spaghetti to me. Then I place the Marked output on a WordPress website.

The Nice thing in Scrivener is that one can organize the text pretty nice. I am a real ad-hoc writer. If I would place my texts the same way as I write it, my readers would lose me at the next alinea.

Btw I saw in the menu that I can switch from normal bold and italics to the MD verslons. But what about quotes and lists?

Just to be clear Scrivener is not a MultiMarkdown generator (with a few exceptions, described in the user manual in §22.4 (pg. 319–325). Try not to think of it as a word processor, but a plain-text editor with benefits. You basically have just about everything Scrivener provides at your disposal, and since most of the formatting tools don’t work anyway, you can use them for whatever else you want if you wish.

Ditto what AmberV is saying. It seems you are saying you are writing in rich text format (i.e. so bold text looks bold in Scrivener) rather than writing in markdown (i.e. so bold text looks like bold markdown code). Scrivener won’t auto-magically convert rich text to markdown. (Nobody else does either than I know of.)

Sorry if I’m misunderstanding you, but in places it reads like you’re not writing in markdown with Scrivener.

At the end I write articles, sometimes with chapters when more than 3000 words, for WordPress. This means that I can put simple HTML with shortcodes in the WP-editor. So I write my texts in Multimarkdown Composer, show them with Marked (and a custom stylesheet) and then copy and paste the Marked-HTML in the WP-editor.

The problem is, that you sometimes loose oversight. That is where Scrivener comes in. I read that Scrivener is able to compile the text as MMD. So I organize my texts in S. and then compile the text (only with the formats which are also available in MMD). So bold, italics, headers from the titles of the files, lists, blockquotes, footnotes. I thought that if I write with only these formats in S, S would also compile these formats into MMD. So I don’t expect miracles, But only that the plain MMD format is exported. No more and no less.

At the end it shows that only lists and blockquotes are not exported. Bold and italic is available from the menu, footnotes are compiled as are headers, although not in the wanted format (# instead of ##). But quotes and lists are disappeared. So if I write them in the text of S itself. And perhaps it is that I am expecting to much from S. So be it.

Thank you all for the answers.

Are you writing your text in Scrivener as you would in Multimarkdown Composer ? Or are you using Scivener’s version of footnotes, bold, etc… Also are you compiling as Multimarkdown ?

If I write my text in multimarkdown, and compile as multimarkdown - I get multimarkdown – footnotes, headers etc… intact.

Do you have some screenshots of what you are trying to do ?

I use S to organize my stuff. I write in MMD with the export to HTML of Marked. This because Marked gives me only the body of the text and MMD exports an entire HTML document.

This html is placed in WP. Now, when I write text in S, because in S you have more oversight when the document is large and exist of a lot of chapters, I use the compile methode to export this document as a MMD. But before that I switch bold and italics to the MMD verslons.

And now everything looks fine, But quotes and lists are ignored. Headers and footnotes are ok. And lately I saw that italics and bold are exported wrong (this is a bug?) because the second * or ** has a blank space in front so it is not properly compiled in Marked. Later I have to check and correct them in MMD.

Conclusion: the compile engine for MMD is very buggy (bold and italics) and for quotes and lists not working at all. This is a pity. I think S is the best tool for organizing the texts, But the export to MMD is troublesome.

Sorry you are having problems. I’ve had zero issues using MMD within Scrivener. Compiles just fine. (I also use Marked2 at the end of the process to convert to HTML).

I specifically compile to a TXT file then convert via Marked2. (This is because I also include some HTML directly in my text and the Scrivener MMD converter handles this poorly at times.)

Based on what you’re describing it’s hard to see why you are having a problem. Clearly something is off, but in general Scrivener handles MMD just fine.

The forums are great for little and specific questions. But you (the OP) seem to be having basic difficulties in understanding how Scrivener handles MMD. For basic issues like this, the manual for Scrivener is your friend - read the chapters on MMD and they should give you the gist of it.

For your specific complaint as to formatting lists and quotes, it seems to me your question has been answered ably - Scrivener does not translate in-document formatting to MMD (or via MMD to HTML). What Scrivener does translate to MMD is binder-level organization -and this means no more than inserting the appropriate-level hash marks in front of document and folder titles.

SO: you want a list to appear as HTML via MMD? this is how you do it in your document - as already stated, you write it as if you were writing it into a text editor:

  • item no number
  • item no number
  • item no number
  1. item with number
  2. item with number
  3. item with number

and as for blockquotes, again it is just as if you were typing into a text editor:

this is a quote
and the quote continues

Italics and bold are also done this way, italics and bold but in this case Scrivener’s authors have added the formatting command to convert the native .rtf italics and bold to Markdown/MultiMarkdown formatting.

Hoping this gets you on the right track at last

– asotir

Given that you have Marked (and hopefully Marked2), my first suggestion is that you open your project in Scrivener and also open it in Marked. That will give you a live preview of what you should get on compile. If you have Scrivener on its default autosave setting then the preview will refresh every couple of seconds.

For your two issues:

  1. Bold and italic. As has been pointed out somewhere else on the forum, the conversion of rtf bold and italic to bold and italic is a bit hit and miss, mainly because the rtf bold code can finish after a space after a word, and does not have to occur immediately after a word. Unfortunately, we can’t see the difference when we type.

So for rtf on screen,

{bold on}my words {bold off}and more words

looks the same as

{bold on}my words{bold off} and more words

but replacing the rtf bold codes in the first gives:

**my words **and more words

which doesn’t work as MMD. While the second gives:

**my words** and more words

which does work.

The recommendation, if I remember correctly, is to use the conversion tool on existing text which you have imported then tidy it up as necessary, but write any new text using the MMD code.

  1. Lists and quotes.

For lists and quotes, have you allowed a blank line between the end of the previous paragraph and the start of the list? Checking just now:

[code]here is my text

  • here is a list
  • point two
  • point three[/code]

doesn’t work properly when viewed in Marked, but

[code]here is my text

  • here is a list
  • point two
  • point three[/code]

does work.