Compile not preserving alignment?

When I compile a document, the alignment is not preserved. This particular document is center aligned, and the resulting file comes out entirely left justified.

I’ve looked at Compile > Formatting, and the ‘Override text and notes formatting’ checkbox. Here’s the problem:

  • If I leave the box checked, my compile font is used, but the alignment is not preserved.
  • If I leave the box unchecked, then the alignment is preserved, but the compile font is not.

How do I get the compile to preserve my alignment but use the compile font? This isn’t something I need for only this particular document - I need this behavior for EVERY document.

(and before you suggest changing the editor font to the same font that I want for compile – that’s not an option – fonts which are suitable for screen editing are often not suitable for compiled fonts that are suitable for printing – I need the option to edit in a different font than I compile with)

Thanks!

You should be able to do this with no problem. I’m not at a computer now so I can’t give you chapter and verse, but the essential points are…

In the compile dialogue make sure you’ve got the all options tab, not the quick summary default set (can’t remember what they’re called on Windows sorry- you want the one with all the options down the left hand side. Pick ‘formatting’ from the list (reading between the lines I think you may already be there.

Make sure override formatting is ticked, then highlight the level and type of element you want to affect. In your case I suspect it’s Document level 1 or 1+, but it will vary. Make sure the column ‘text’ is checked. All that’s just to make sure the basics are covered - I’m sure they are.

Now you’re ready to override the settings. If you’ve got the text button checked as above you should see dummy text below the standard formatting buttons. Click inside the dummy text and those buttons should become active and you can alter any aspect of the text, including alignment and font (you may have to highlight it first). The dummy text will change to reflect your options. This is very close to the process you use to set default text in the general options dialogue and the buttons look the same, I think. From memory, the button for font is on the left hand side and it’s a stylised ‘A’.

That’s it. If it’s not working after that then check you still don’t have preserve formatting set or ‘compile as is’, and make sure you haven’t got the ‘Quick Font Override’ settings checked (they’re also in the detailed compile options dialogue).

Hope this is enough to get you on the right track.