Compile Not Retaining Text Colour/Color

Hi All,

I have italicised grey text in my MS that I need to retain post-compile. I want to override the font and paragraph spacing because I haven’t written my MS in TNR with double line spacing and that’s what the agent will want.

Because ‘Remove Text Color’ ISN’T checked in my compile options, I would expect Scrivener to keep my grey text. But it doesn’t. Regardless of what I compile for (MS Word / PDF) my grey text is changed to black.

The only way I’ve found to work around this is to use the Override Text and Notes Formatting Options and check ‘Override Font Only’. Then I have grey text post compile… YAY!! BUT!! I then have 1.5 line spacing because it isn’t (obviously) overriding the paragraph spacing because I’ve told it to override the font only.

So… how do I keep my grey text AND my double line spacing?
And… why doesn’t the ‘Remove Text Color’ not remove the text colour when it’s unchecked?

Any advice would be MUCH appreciated before I have to go through an entire Scrivener MS and change 55 chapters to double line spacing.

Thanks so much!
Gilly

Gilly, I use colour to define different types of paragraph, and I also have revision mode turned on so that edits appear in red. When I compile, text colour, italics and boldface are preserved. I think the answer for you is to use the formatting pane to set the line spacing for each text level, but nothing else, and use “Quick Font Overrride” to change the font. I have projects I share with Windows-using collaborators, so which need to be in TNR as that is safest between platforms, but when I compile, I want the output in Adobe Garamond Pro so my NWP macro can run through it to create a document with fully cascading styles.

I have set up my own compile preset on that basis that works for me.

:slight_smile:

Mark

Hi Mark, I’m so grateful for your help, thank you.

I’m a bit confused still though. If I want to use the formatting pane to set my Text line spacing to double, the ‘Override Text and Notes Formatting option’ needs to be turned on, otherwise the formatting options for the Text are greyed out. But, as soon as I turn this on, although I can then set double line spacing, it overrides my font colour regardless of the setting for ‘Quick Font Override’. Am I missing something? I feel like I must be.

When you compile and manage to keep all your colours, are you changing the line spacing too? Do you have ‘Override Text and Notes Formatting’ switched off when you compile?

Thanks so much.
Gilly

I’ve tried with one of my test projects—as usual with AGP as the font in the editor—and exported it with a different exporter from my standard one. I set the line spacing to 2 in the text formatting boxes, and the “Quick Override Font” to TNR and compiled. My paragraph colours were preserved—I use minimal variations on black which are indiscernible to the eye but can be picked up in my NWP macro, so it’s not much point giving a screenshot of the compiled text!—and the font was TNR throughout and the line spacing is 2.

So, Gilly, I think the answer is you’re looking in the wrong place in the Compile dialog. From your screenshot, you’re looking in “Transformations”. You need to be looking in the “Options” in the “Formatting” dialog. You need “Override text and notes formatting turned on”, then click on the little “Options” button to the right. You get a pane like this:

That is how mine is set, and as I say, the colour is preserved and the line spacing and font is dealt with.

Give it a try.

:slight_smile:

Mark

Er yeah, that worked. But it didn’t yesterday when I tried your Quick Font Override suggestion. I haven’t changed anything this morning, my settings were exactly the same as your screenshot. But I restarted Scrivener and reopened the project and now it’s working. Hmm… maybe it got itself in a pickle.

I really appreciate your help Mark, thank you so much, I wouldn’t have thought of using the Quick Font Override if you hadn’t suggested it. It’s working and I’m so grateful for that! Time to submit!!

Gilly

Great! It’s a pleasure to have been able to help.

Good luck with the submission.

:slight_smile:

Mark

Thanks! I’ve been developing elephant skin over the years to prepare myself for rejections! My uni lecturer said, “You aren’t a writer until you can paper your bathroom wall with rejection letters.” So I’m ready for that! I plan on being proud of my rejections because it means I’m putting myself out there… and that’s been a brave step. Three years it’s taken to write this book and it feels like an appendage!!! I just hope the agents don’t hack it off!!

Take care Mark and thanks again for all your help with my questions.