compile>options>delete struck-through text not working

When I select "delete struck-through text " in the “options” pain of the “compile” window, the resulting PDF still shows the text that has strike through style added to it (with the only difference being that the strike through style has been removed from the text that has the strike-through style added to it in the pre-compiled scrivener document.

???

Hey, Randall.

Just to check the issue isn’t with a specific file, I have created a sample project with struck-through text that does compile correctly, and I have attached it to your other post.

Does that sample project work for you? If it does, can you provide a sample project that doesn’t compile correctly so that we can try to work out what is happening? Or perhaps the sample provided will help to identify an issue with your own project.

Please see: https://forum.literatureandlatte.com/t/is-there-markup-to-exclude-text-stings-from-compile/49836/3

I am now assuming the issue is simply a poorly titled compile settings option. The option “Delete struck-through text.” doesn’t at all do what it says it will do. The text is not deleted (“delete” is not a word that a writer wants to see anywhere near their manuscript). What seems to happen with this setting chosen is that strike-through formatting is removed leaving the text itself right where it is in the compiled document (just without the strike-through style applied).

Might I suggest an alternative wording instead:

  [i]remove all struck-through formatting[/i]

Strike that! [sic] There is a need for a means of easily and intuitively annotating text such that one might have the option of text, so annotated, omitted from the compiled document. If it were me, I’d replace the current single option:

 [i]delete struck-through text[/i]

With the following two options:

  [i]remove all struck-through formatting[/i]
  [i]omit all struck-through text[/i]

Randall Lee Reetz

From the manual, Section 23.4.3 General Options:

Delete struck-through text Any text that has been struck-through in the output
will be stripped out of the compiled copy. If you use these marking
for editorial purposes, to “soft delete” text, this is the option to use to implement
those edits. When disabled (as it is by default), the text will be
formatted as struck-through text if the document type supports that form
of formatting. They will otherwise look like ordinary text in formats like
plain-text. <<

Based on the manual’s description, this option is supposed to do what its name indicates: Delete struck-through text.

You may want to email L&L support directly.

https://www.literatureandlatte.com/bug-reporting

Best,
Jim

A sample project and a PDF from that project showing how this does work on a Mac have already been supplied for the OP on two threads:

https://forum.literatureandlatte.com/t/compile-options-delete-struck-through-text-not-working/49837/2

https://forum.literatureandlatte.com/t/is-there-markup-to-exclude-text-stings-from-compile/49836/3