Compile- page breaks

When I compile, Scrivener loses (removes?) the page breaks between documents. How do I insert page breaks before each document or section? Thanks in advance!

In Scrivener 2 page breaks were handled on an ad hoc basis using the Page Break Before in the Inspector or on a check list in the Compile dialog.

In Scrivener 3, compile works quite differently. Each document has an assigned Section Type (either automatically or manually). In Compile, each Section Type is assigned a Section Layout and it is the latter that determines the look of the docs of that type in your output. Page breaks are controlled by Section Layout settings. So, whether there is a page-break-before is now determined by the assigned Section Layout (and conditions under which this happens can be set in fairly sophisticated ways).

Document <-- Section Type <-- Section Layout <-- page-break settings.

Hope this help.

Thank you. I was trying to do it in Compile, but had not yet discovered the Section Layout and the Page Break Settings. I will check this out first thing tomorrow!

I definitely recommend checking out the videos on Compile that Jonny put together (see our Learn & Support area). They cover everything from the basics to advanced use of the new Compile feature.

“Page Break Before” in earlier versions of Scrivener (like “Compile As-Is”) was really a bit of a fudge because you didn’t have full control over how any arbitrary document was formatted on Compile - it was limited to outline structure. But in Scrivener 3, Section Types allow you to tell Scrivener what any particular document is: “This folder is a chapter heading, this document is a scene, this document is a title page.” Then, in Compile, you choose how each Section Type is complied by assigning Section Layouts. So, you can tell it that title pages should be compiled as-is, that chapter headings should just print out the title and have a page break before, and so on.

It takes a bit of unlearning the old system if you’re a Scrivener 2 user, but it provides much more flexibility, because you can now thing in terms of what each item in your binder is rather than what level it is nested at.

All the best,

You couldn’t find anyone who talked faster?

So, the only thing that I could find to remove the page number from the title page was to put the title page in a separate folder titled “Front Matter.”

I tried the different options under (headers and footers" and “different fist page” and deleted the the page number code from the first page footer, but none of that had any effect — the page number still appeared on the first page. That is until I created a “front matter” folder and put that page into that folder.

Not sure exactly how or why it is working correctly now (no page number in the footer of the first page), but somehow, it is working now, and I am glad for that.

Did you try this?

By default this is set to start the regular header/footer after front matter, but you can change it to a specific page if you would prefer. This involves creating your own Compile format (duplicating one and changing this setting in “Page Settings”, basically). Putting the title page in a “Front Matter” folder alway works, of course, if you don’t want to play with the settings.

All the best,

Thank you, Keith. No, I had not discovered that drop-down (or pop-up?) menu. How do I get there? Another thing to discover! Thank you. Lots to learn.