Compile Preset Not Working

I have been using Scrivener for many years and have never run into this issue before. I hope someone can help me out with this as I’ve been fighting with it for hours.

Both my husband and I are authors and use Scrivener, both on MacBook Pros and updated to the newest Scrivener versions and all updates on our machines. Some time ago I created a compile template for our editing proofs. I imported it into my husband’s Scrivener and it worked perfectly in both of our programs. Then a few weeks ago, I wiped my system and installed a clean copy of Mac OS X 10.8.2 and installed Scrivener again. I imported all templates and settings, which I’d saved. And now my export template for the editing proof doesn’t work. Even though I’d taken it from my husband’s machine, where it does work, and on the same manuscript file.

I have tried everything I can think of, including looking over all the settings on our two programs side-by-side. The issue is, when it exports for .doc, it doesn’t keep any of the header/footer information nor the chapter page breaks. This is a huge issue as I need to go through the whole manuscript fixing things before sending it to my editor. Not fun.

I can open my Scrivener file on my husband’s machine and export it properly, but I’d really like to do this on my own machine. Any thoughts?

Thanks for the help. :slight_smile:

What are you opening the compiled .doc in? Text edit? Pages? In other words having totally refreshed your MBP, are you using the same wordprocessor as before?


Yes, I’m using the same word processor in both cases. I’m opening the compiled .doc in Pages. I even tried opening it in Word, but same issue. On my husband’s computer, it opens in Pages and shows everything perfectly. The strange thing is, all my other compile presets work perfectly such as for Kindle and ePub.

You say that the compiled file opens properly on your husband’s MacBook. Is it compiled on his Scrivener app, or are you copying your compiled file over to his machine? If it’s the latter case then I doubt that the problem lies with your export template. Have you tried repairing permissions, and checking your Pages settings?

No, I’m compiling on each machine and opening the file on that same machine. I also tried opening my compile on my husband’s machine and it looks the same as it does on mine, thus it’s not a Pages problem, but a Scrivener one. I haven’t tried repairing permissions. Will try that and see, although my machine just had a clean install so it’s not likely the problem. I’ve had no issues with any other programs or settings.

My guess is that you don’t have Java installed on the computer you just wiped out, yet. Apple has stopped including that as a default part of OS X, and it now needs to be installed for programs that use Java. Most of Scrivener does not, but one part in particular can optionally use Java: the improved format converters. How you’ve described the .doc output sounds a lot to me like Apple’s vanilla .doc converter (which is missing features like page breaks and headers and footers; losing those is a classic symptom of using it). What you want to do is visit the Import/Export pane and click the big “Set Up Improved MS Word and OpenOffice Converters…” button. This may at this point entail downloading and installing Java from Apple’s server. This is a painless procedure that is 100% automated, so just wait for it to complete. Next, select the “Enable custom converters…” option right above that button, if necessary.

Now try compiling to .doc again and see if you get good results.

Thanks, I will look into it in the morning. I have a feeling this isn’t it because I remember checking off this setting as it was checked it my husband’s Scrivener settings, plus I installed Java for another program. As I said, though, I’ll give it a go and see what happens. If you think of anything else, let me know. Thanks for all the help! I’m sure we’ll figure it out. :smiley:

Okay, and one other thing you can do in the meantime is use RTF. That is Scrivener’s native format and so thus the most accurate. Everything else is going through one filter or another. Since most word processors (Pages excluded, mysteriously; if you prefer Pages, just open the RTF in Word and save it as a .doc from there) load RTF files just fine, this isn’t a problem.

That should at least get you back into doing real work while the problem gets solved.

Okay, I made sure I have Java installed. I have the newest version.


I clicked the button to “Set Up Improved MS Word and OpenOffice Converters.”

No Converters.png

So, this didn’t work. I tried exporting in RTF as you suggested and I still don’t have headers and footers, but I do have page breaks! Very happy about this.

So, any ideas what to try next?