Compile problems after updating to 1.9.5.0

Hi, I never had any problems with the compile function. However, after the update all compiled texts end up showing in a very small font–really, unreadable.

I tried to change font type and size in option–>editor font, and also in the main editor window. I tried to change zoom. No luck. Before everything was smooth. Now nothing works.

In compile, with the ‘override text and notes formatting’ option activated I manage to have a font somewhat bigger, but something’s wrong there too because no matter how I format my text from there. It will show up all wrong anyway. (no centered titles, for example)

Could you please help me to sort this out?

I’m sorry you’re having some trouble! We’re working on fixing a font bug that was introduced with 1.9.5, so it’s possible the problem you’re seeing is related to that. If you’re willing, it would be very helpful if you could send a zipped copy of the project showing this problem to windows.support AT literatureandlatte DOT com (mark it Attn: Jennifer in the email subject). You could use Save As to create a copy of the project and then delete all but one or two sample files; as long as it still compiles with the font problem, that’s all we need. This way we’ll be able to see directly the fonts in use, the compile settings, and the document encoding, which should help determine whether it’s something that can be fixed by adjusting settings on your end or part of the font bug we’re looking at–and if the latter, having the sample project will help us track it down and resolve it more quickly.

We can discern a possible font bug by examining the RTFs in the project’s Docs folder through Windows Explorer’s Preview Pane. This deploys Windows’ Rich Text Control; it’s like opening the RTF in WordPad, but read only.

My Scriv docs are created almost entirely in Cambria typeface. Once saved in 1.9.5.0, however, they appear in a sans serif font in the Explorer Preview. If we compare RTFs saved in 1.9.5.0 with those last saved in 1.9.0, we’ll see the formatting instructions at the top of the doc have changed:

1.9.0

{\rtf1\ansi\ansicpg1252\uc1\deff0 {\fonttbl{\f0\fnil\fcharset0\fprq2 Cambria;}}
1.9.5.0

{\rtf1\ansi\ansicpg1252\uc1\deff0 {\fonttbl{\f0\fnil\fcharset0\fprq2 Cambria-BoldItalic;}{\f1\fnil\fcharset0\fprq2 Cambria-Bold;}}
Note that if we drag any such document from the binder into a Windows folder, the titled RTF file Scriv creates will use the 1.9.0 style initial text block, and show with Cambria typeface in WordPad and in the Rich Text preview!

Though the numbered RTFs in the project’s Docs folder are really Scriv internals, it would be best if the previews would again match their appearance within Scrivener. I suspect this would reduce the likelihood of font problems in the compile.

Rgds — Jerome

I sent you the zipped file you requested. I would add that I have the same problem also with new documents, not only those I had created with the previous versions.

I just wanted to add that I rolled back to version 1.9.0.0

So doing every compile problem disappeared. I downloaded the older version 1.9.0.0, installed it, and opened the projects I had been toiling over in version 1.9.5.0. Compiled and… voila’.

I looked at the files in Sigil ( sigil-ebook DOT com ) and my understanding is that the base the new version uses to define the size in percentage of all the fonts in a projects is too small or not defined. I’m not a programmer. I might be saying something stupid, in any case these are my two cents…

Thanks for sharing the project! It looks like the percentages for the font sizes in ebook formats are being miscalculated. The most commonly used font size in the compile should be coming out as 100%, with everything else then calculated off that, but it seems to be still working off 12pt as the 100% base regardless of the font sizes used in the compile, and then flipping the percentages, so the larger the font is, the smaller the percentage. Since you’re using mainly 18pt and 24pt, you’re getting font sizes around 50%-75%.

We’re working on an update to fix this and a couple of other bugs that came into 1.9.5. That should be out soon, but if you need to correct this in the meanwhile, you can open your compiled files in an epub editor like Sigil and adjust the font size percentages in the stylesheet.css there.

EDIT: Or use 1.9 to compile. :wink: You may want to check that, though, as I believe 1.9 is also using 12pt as 100% rather than the most common text size, so your fonts may still be coming out too large. Depending what you’re doing with the files that may not matter, but some sellers require default formatting for the body text, so 100% font size.

I am having the same problem.
Following.

Best solution for now is this - reinstall 1.9.0.0. That is the measure I took and now I’m back in the comfort zone. However, the first measure to take is always have a System Image backup. For some reason I forgot that I had the image to take me back to 1.9.0.0. If I would have remembered that I would have used it. Forgetful me!!! Anyway, use the below link while it is still available.

Here is the L&L link:

https://www.literatureandlatte.com/scrivWinChangeList.php

Same problem here guys.

How do I roll back to previous version?