Compile Problems

I knew I was in for trouble because ever since upgrading to 3.0 my word count has been stuck at “0”. When I go to compile in the right hand column I get the message “No documents selected to compile.”

When I choose different sections of the document in the Compile drop down, nothing changes. I get two random documents included if I choose “search results” or “synced documents”. If I select a bunch of documents I can get them to compile but that seems very clumsy.

I’ve tried applying a filter. That didn’t help. I’ve read through the manual. Not helpful. It seems to assume that you already have a populated list of documents in the compile window. I don’t. My Scriverner file originates from a template that I downloaded so it doesnt’ have a folder specifically named “Drafts”. Not sure if that’s an issue. I’ve tried checking the section formats (and changing them). Seems to make no difference. Totally stuck.

The “Draft” folder can be renamed but is always a white icon with a blue bar down the left hand side. Select that above the Compile contents list - assuming there are documents inside the Draft folder, of course. If not, you’ll need to move them into it.

All the best,

The Drafts folder can be renamed, but there is still only a single folder that will contain your documents that can be compiled.

Under what top-level folder in your project are the two documents that show up in search during compile? That’s probably your re-named Drafts folder – try creating additional test documents there and see if they show up in the compile results.