Compile pushed text off page edge + more - what did I do?

I know it is me. I know I have messed around too much. I have been reading the forums and watching the tutorials and trying the different compile features and now I’m a mess.

I have 2 issues - one, I have managed to somehow push the text off the page when I compile and two, I can’t seem to get a clean compile without the chapter numbers.

What I have - a collection of essays into on book.

What I want to do - export them with the titles of the essays and nothing else. No “chapter one”
I can delete the word “chapter” in the prefix but I still get the word “one”

And I have no idea what I did to push the text off the page. I moved the ruler on the screen to 12 for when I was working so I could use more of the screen but I thought it would format to the standard layout. I have tried using various templates and get the same issue so I know I have mucked something up pretty well. Any ideas where I should start?

Thanks.

Attached is an example of what is happening with the text.

  1. The text running off the page means you’ve set the right-indent off the printable area–12" would definitely do this. It sounds like you set this in the editor, which means it is possible to override it during compile if you wish. To do so you’ll need to tick “Override text and notes formatting” in the compile Formatting, and then make sure that there is a “0” right indent for all the document-type rows there. “0” means that the text will wrap at the margin when compiled.

When set to “0”, the right-indent marker should adhere to the right edge of the ruler regardless of the width of the editor. You can select it and drag it just off the right edge of the ruler and release to set it there–it should spring into place. You can also choose “More…” from the spacing drop-down menu in the format bar in the compile dialog and make sure that the right indent is set to 0.

You’ll want to check on that for all the text displayed in the preview, i.e. click into the main text so it’s highlighted, then set the indent, and then click into the title text (if there is any) and check the indent, etc.

If you’re not overriding the formatting during compile but sticking with the editor formatting, you’ll need to reset the indent for every document in the project directly. The simplest way to do this is by making the default formatting use a 0 right-indent; set this in the Editor option of Tools > Options. Then you can select all the documents in the binder and use Documents > Convert > Formatting to Default Text Style to update them to the default formatting. The only hitch here is that if you have special formatting throughout the documents–e.g. different indentation, different fonts, different sizes–it will all get overridden. You’ll have a chance to preserve some aspects when choosing Documents > Convert > Formatting to Default Text Style, but you won’t be able to preserve the font (you can preserve font size) and you won’t be able to preserve tabs and indents since you’re specifically doing this to update the right indent.

You may be able to mix and match, i.e. if there are some documents with non-default formatting you need to preserve, you can load these individually and adjust just the right-indent in the editor ruler for all the text. Then you can select the remaining documents that are safe to update en masse and use Documents > Convert > Formatting to Default Text Style.

  1. Some of the compile presets include numbering in the title prefix, so my guess is that’s where it’s coming from. You would have seen the placeholder marker when deleting the “Chapter” text from the prefix, however, so if you didn’t, or you removed it already, the numbering must be coming from elsewhere. Do your document titles in the binder include numbering or placeholders? (The placeholder would be something like <$t> or <$w>.)

I’d check the prefix first. In compile formatting, go through each row in the top table and check for the number appearing in the preview area below. If you see it, it’s part of the title prefix or suffix, so click on “Section Layout…” and then remove the placeholder.

A belated thank you, for the detailed response. (Our internet was out for a few days.)

So I have it somewhat sorted but I fear it is more of an accident than truly understand what I did and when I did it but I’ll keep reading and keep trying.

I just didn’t want to not say thank you for the help.