Compile Query

How do you change what Scrivener compiles?? I was poking around in the Compile options and I have noticed that Scrivener seems intent on compiling the complete wrong section of my manuscript - despite the entire section being de-selected for compilation. When I go to ‘Compile’…its lists this wrong section, and won’t let me select anything else.

In the attached screenshots, you can see the ‘Manuscript’ and ‘Outline’…the outline is the outline, it is not to be part of the compilation at all. The manuscript is the novel - but Scrivener seems focused on trying to compile the outline, and I can’t see any way to change it.

Any ideas as to what setting I need to change?


. . . . . . . . . . . .

Change that for your manuscript from the drop down list. That simple.

There are three “blessed” top-level folders in the Binder. They are Trash, Research, and one that is by default named Draft or Manuscript. These folders are recognized as special by Scrivener (no matter what you name them!). For example, when you delete a document, it moves into the Trash folder. Similarly, the contents of Draft/Manuscript folder (or some subset thereof) are always the target of Compile. You cannot Compile anything outside that folder* (* Front matter is a special case, but let’s not confuse matters.)

So now, which of these top-level folders is the blessed Draft folder in your project? I am guessing you renamed it and put your outline in it.


It would be, if the option to select the manuscript from the drop down menu was in there, but its not. I go in there, and it only has the Outline and all the subfolders underneath, sadly :frowning:

Ah…that makes sense. I had started this out initially as just the outline - then decided with the way Scriv works, I’ll just do the manuscript as well to keep it all in one project.

I was not aware of these ‘blessed’ top level folders and how Scrivener treats them. I’ve learned something.

I renamed the folders and swapped everything around. Compile is now focusing on the right folder now - as perhaps it always was aha. Thanks for the assist!!

1 Like