Compile screwed up for Word

Environment: Windows Vista Ultimate SP2, Word 2003, Scrivener 025

Tried to compile into Word for the first time and it failed. Text streams as single letters down the page. PDFs are working fine. See attachments.

It first failed in my WIP project so I created a dummy test project to be sure. I don’t know if this is a known bug, but I would like to be able to compile into Word so I can do revision.

Steps to reproduce:

  1. Create new Blank project
  2. Add text to file (see screenshot)
  3. Click File->Compile…
  4. Set Compile settings:
    a. Format As: Novel Standard Manual Script Format
    b. Compile For: Word Document (.doc)
  5. Hit Compile. (see compile results)

Thanks in advance!

Linny
PDFCompile.pdf (6.09 KB)
WordCompile.doc (893 Bytes)

Ok, 026 has helped things along, but a couple of things:

  1. I just noticed that all my italic text has become underlined text

  2. Could we not have the same formatting we set in scrivener be compiled through to Word? My preferred Times Roman default came out as courier…maybe this is a template thing, which I haven’t really gotten into…

Ok, I messed around with the templates and got what I need (kinda) and so I’ll just ignore that default template since it may be some sort of standard formatting thingy I’m ignorant of.

But I do have to mention that the inconsistency with quotes is a bit of a bother (see attachment). I have different types of double quotes appearing. And maybe it’s something I did when I was writing or copying…but having to clean it up on each compile may be tedious…
mismatch_quotes.jpg

Although I’m a Mac user, my guess that your problem with compiling to Word coming out in Courier is that you were using the standard novel format template, which has Courier set as the font as that has always been the standard submission font. You should be able to change it in the Formatting sheet of the Compile dialog.

This sounds like material brought in from another (version of the) text, perhaps copied and pasted, vs material typed with current settings. So, one of the sets is using the UTF8 code for straight quotes, the other has the code for typographer’s quotes.
If copying and pasting, have you tried using “Paste and Match Style” — I am assuming the Windows version has an equivalent command?
For cleaning up, does the Windows version not have “Convert Straight Quotes to Typographer’s Quotes” and vice versa in a “Convert” option under the “Document” menu?

Mark

I am so talking to myself. :confused:

Anyway, I’ve figured out how to mess around to change quotes and after stuffing around here and there, and a bit of finding and replacing characters etc I can get exactly what I want.

I have to say, the compile process is really tedious, especially for a novice like me. I guess I just need to get use to it.

Thanks for trying to help Mark. After a bit of hair pulling, I finally got what I needed. I’ll keep the copying and pasting quotes advice in mind next time.

Pleasure …

The thing about “Paste and Match Style” is that it strips out all formatting and only pastes in the plain text, which then takes on the style you have set in your preferences. I have actually changed the shortcut keys on my Mac, so that what is normally the ordinary “Paste” gives me “Paste and Match Style” and ordinary “Paste” is set to the other … saves me a whole load of bother.

I know what you mean about Compile, but it’s one of the most powerful things in Scrivener, to my mind. It means I can type away in whatever font, etc. combination is best for me on-screen, knowing that, with a bit of work, I can then compile my text into a totally different format for the purpose for which it is intended. And do remember, all that faffing about only needs to be done once if you then save the Compile settings to be able to reload them at will for other documents or projects.

Mark

Yep, I grudgingly forced myself to click around on more buttons and then saved my compile settings.

I still think that you go to the effort of making your scrivener pages to look and a feel a certain way, that it wouldn’t be unreasonable, as a default, to easily spit that out the other end with a click of a button or two. That’s just my feedback.

Anyway, after the ‘faffing’ about I’m content again. :slight_smile:

Mark, I just noticed you’re a Mac user, what are you doing hanging out here and answering my whinging?!?! Shoo!

But that’s the whole point … the way you want your Scrivener pages look and feel doesn’t have to be the same as the look of the compiled version. Take the example of someone over in the Mac forum, who wants to output the same text in ePub or .mobi format on the one hand and to be able to drop straight into a print finishing program on the other; he can operate however he wants in Scrivener, then all he has to do is choose one compile format and output for ePub or .mobi, then choose the other compile format and output for the print finisher …

Personally, I loathe Times New Roman, but that’s what I need to send to all my colleagues and collaborators; I don’t want to look at it on screen. And when I want to produce a PDF for my students, I want it in Adobe Garamond Pro 10 pt. For the actual writing process, I certainly don’t want to be squinting at AGP 10 point on my high-resolution MacBook Air screen, so I switch back and forth between Optima and Baskerville … I like Optima best, but there are glyphs I use periodically which aren’t available in Optima, but are in Baskerville. Compile formats to the rescue!

Hey, not all Mac users are totally anti-Windows; for some of us, we are simply more comfortable with OS-X and our Mac hardware. And helping people, or trying to help, is one of the reasons we are here … No? Anyway, I’ll “Shoo” if you want me to! :wink:

Mark

Ok, I give up, you win the compile argument. I’ll let you miss my point re “as a default”, I’d like it to look as I see in my screen. And that custom means to me that I would like it to looking different.

I just want Scrivener to cater for lazy bones like myself who doesn’t care to think, that every time I click a button it knows what I want even before I think it. It seemed to be doing a good job so far…So imagine my shock when I eagerly finished my work to a point I was happy, and excitedly clicked on compile. It’s like the the program decided to choke and splutter (ok, so there was a bug)…and out came something I didn’t quite recognize.

But not to worry. Now that I know there are Mac users who aren’t totally anti-Windows and are here to help, who needs Scrivener. I’ll send you an outline of my novel, maybe you can write it for me?

I’m teasing Mark!

PS: How can you loathe Times New Roman, poor font…

If you would like the compiled version to look like the on-screen version, simply don’t use the various formatting options in the compile dialog. You can use the compile function to completely re-do the formatting, but you don’t have to.

The only wrinkle is that if you are using one of the templates, it may have compile options pre-set, which may or may not be what you actually want.

Katherine

As Katherine said, you can just choose in the compile settings not to override your formatting, so you’ll get your text coming out just like you see it in the binder. Make sure you’ve clicked the “…” button in compile so you can see all the options, then click the Formatting tab and deselect “Override text and notes formatting”. Also take a look at the Text Options tab to make sure “convert italics to underlines” isn’t set.

There will be a preset for this, so that instead of choosing e.g. “Novel Standard Manuscript” Format you could choose “Original” and have your compile generate a document with the same formatting as you see in the editor. Even if you then wanted to tweak it a little for which elements were included or such, this would be essentially the “one click compile” method you’re looking for. We just didn’t have a chance to get everything in for the beta yet, but this is coming. Meanwhile you can certainly save your own preset by setting up compile as you want it (deselect the “override” box and select which elements you want–e.g. titles and text–set your text options, etc.) and then clicking the Save button and giving a name to your settings. You’ll be able to load this in other projects then and so won’t have to repeat the set up.

Mark’s point about being able to change your formatting etc. in compile, so that you can work with what feels comfortable to you in the editor and produce something slightly different that maybe looks better in print, is part of the general philosophy behind Scrivener–it gives you freedom to work the way you want when writing without having to worry then whether everything is standardized and tweaked just so. But your desire to just output exactly what you see is also perfectly valid, and I’m sorry that you had a bit of a struggle to do it. Once we get the bugs worked out and all these features are in place, the manual will get updated to reflect all this and the chapter on compile then should make all this easier to understand. (One day, we’ll even manage to get a quick tutorial video up to go through setting up compile for various methods…) And like I said, there should be a preset as well that sets up compile to barely touch your work and just generate the text as you see it, and we just haven’t gotten that in there yet.

Thanks Kewns. But that’s been my point, I don’t like the presets and more specifically the presets I get as a default if I barely touch anything. Just feedback I wanted to give to the Scrivener makers. I completely get it that I can get what I want after some fiddling about. :slight_smile:

MM - Not you too, I understood Mark’s point - didn’t you see? I gave in! :wink: And “Original” as a predefined format is what I felt the compile was missing. It seemed obvious to me so I didn’t get why I had to mess around and customize my own. I think it should be the default over the “Novel Standard Manuscript”. I stress, I’m only giving feedback for the novice user experience, I don’t actually need any instructions on how to do what I need - just in case you think I still need further help. :slight_smile: Thanks as always!

Which preset comes up as the default should actually have to do with which project template you used when creating the project, e.g. if you choose the Novel template then the compile settings for Novel Standard Manuscript should be the default, but if you choose the Blank template then Original should be the default, etc. But along with that, the special template like Novel should also have the About file that explains how the set up, including compile, works; in most cases it will also have a sample PDF showing what the output will look like if you work in the template as it’s presented. So part of this is also just that the templates are not spruced up for Windows yet, as Lee’s been working on getting in the different features and so forth. That along with the updated documentation should go a long way to making this much easier to understand.

Sorry if you felt I was patronizing by explaining how it’s done now; wasn’t my intention. Maybe it’ll help someone else. :slight_smile: And I do appreciate the feedback–I think it’s mostly just a matter of things not being all the way there yet for the beta, and that the finished product will have things set up more closely to what you imagine.

Oh, I didn’t think you were being patronizing. I was just worried that I was going to get another bout of well meaning help for something I figured out very quickly myself yesterday. I’m not a complete spazz :slight_smile: And between Mark, Katherine and yourself, it’s been well and truly answered. Didn’t want to waste more people’s time when all I was doing was having a gripe.

I was particularly shitty about the Compile function because to me, it was my ‘Escape from Scrivener’ button. So I was surprised it wasn’t easy peasy straight forward and that it spat out a document I didn’t care to look at. I look forward to the official release being closer to my expectations.

Please don’t take this the wrong way - but that Novel Standard Manuscript…WTF?
I may be misinformed, but I thought Times New Roman and the use of Italics, would be considered Standard Manuscript format that Editors accept. I mean, I use italics a lot in my writing, and that default conversion to underlined text just mutilates the expression I’m trying to achieve. I just don’t see how that can be a useful default for the Novel Standard Manuscript format. I’m sure there will be other people like me being thrown off by the same thing. I mean who would actually use that template as-is…? Still, if that’s what people within the industry expect, then that’s fine. It just doesn’t make sense to me. :confused:

Nope it doesn’t make sense, but Standard Manuscript Format is Courier with underlines instead of italics. It dates back to typewriter days – part of the reasoning is that using that format for everything allows editors to estimate page counts and column inches fairly precisely.

A smart author would look at the particular editor’s guidelines before submitting, though, as there is very wide variation in what people want to see. (Back in my editing days, the only “standard format” manuscript I ever saw came from a rank amateur who’d clearly spent more time reading Writer’s Market than studying my publication.) Which is why Scrivener has (and needs) such powerful Compile options: you can submit the same manuscript to Editor A in Courier, double-spaced, with underlines, and to Editor B in Times New Roman, italics, 1.5 space, while still doing your own writing in Optima 13.

Katherine

Since Scrivener was not made for the clunky old typewriter, then off with the unpalatable default, so that unsuspecting amateurs like myself don’t need to be confronted by all that ugliness. I go back to MM’s reasoning…I still think “Original” is a much more reasonable. Not point in making us click more buttons than we need to when we just want a quick document. But it’s a minor point.

Katherine, I mean this in the nicest possible way…I really get it with the all powerful Scrivener compile options! I know it will be super handy come time to submit if I get that far. I’ll never complain again. :frowning: