Compile to .docx Problem

When I compile my project to .docx(compiling to .doc has same issue) and open it with Pages, every first word of the paragraph in all my multi-paragraph footnotes become superscript, except the very first word of a footnote.

Images below show the issue.

Scrivener 3

Pages, after compile

My project has more than 200 footnotes and quite a lot of them are multi-paragraph footnotes, so it’s kind of a big issue for me. I had no such issue with Scrivener 2.

If this issue is not fixed in a week(and a half, perhaps), I’m screwed. (Then I should manually fix all the… :frowning: )
I’ll be using Scrivener nonetheless, though.

I can confirm this behaviour, and it only happens for newlines — if you use a line-break there is no problem (first break is a linebreak, second is a newline):
Screen Shot 2017-11-22 at 19.28.43.png

So one solution would be to do a search-and-replace of newlines for line-breaks only in the footnote stream?

The easiest way is to show invisibles, then insert a line break (⌥⌘↵) and a newline (↵) and copy them to the find / replace fields:


It works! Thank you very much.
Now I have to go to change all the rest… :laughing:

If footnotes supports line spacing and if I can change footer position(for the page number), I don’t even need to compile to .doc.
But I suppose a workaround doesn’t exist all the time… right…? :wink:

This still seems like a bug in the S3 compile, so it would still be good if KB could check what the problem is.

I don’t know if there is a solution to allow you to dump word, but you can try to see if one of the new native compile outputs can now handle footnotes as you want?

Thanks for the bug report. Unfortunately the bug is not in Scrivener (if it were I’d be able to fix it straight away), but in the third-party conversion tool we use to create .docx files (Aspose). Scrivener generates RTF internally and then uses Aspose to convert the RTF to .docx. I have reported the bug to Aspose. Because Aspose is a (not inexpensive) tool we pay to use, their support is good and they tend to be efficient at fixing bugs, so hopefully they’ll have this squashed soon. Apologies for the inconvenience in the interim.

In the meantime, another alternative is to export to RTF format and open that in Word, then save from Word as .docx.

All the best,

I’ve tried to export to RTF format, but it seems footnotes are not included in the exported RTF file.
Same result when I compiled to RTF format.
And I tried to export “comments & footnotes”, app says there is none of those to export.

I’ve tried both Inspector footnotes and Inline footnotes. Same result.

It’s not a problem for me, for now at least.
I’m just reporting. :slight_smile:

I think Keith meant compile to rtf.

Is it possible that you have Remove Footnotes selected in your compile Options (under the gear icon in the rightmost pane in Compile dialog)? There are also settings there that might convert your footnotes to endnotes – which could also make them not show up where you were expecting them.

Because your footnotes would generally be included when you compiled to rtf, so I think this problem must be down to a setting.

gr /
Yes, I agree. I’ve tried both export and compile to RTF format.

None of the checkboxes under the gear icon are selected.
Since it’s a test project with a couple of lines and a couple of footnotes, it wouldn’t matter even if I used the setting that converts my footnotes to endnotes, which I did not.

When I compiled to PDF format or DOCX format with the same(well, sure it’s tiny bit different by the format) compile format, footnotes appear just fine.
And the compile format I’m using for the test is basically a copy of a default format.
I didn’t change many options.

Is it just me having this issue?
With my version(3.0(58)) it’s pretty easy to replicate the situation.

It’s reasonable to assume that I messed up some setting to cause the problem but I’m not sure what it is.
I’ve double checked the things you’ve mentioned.

The RTF export is nearly identical to the DOCX export. How are you opening the RTF file, though? If you double-click on an RTF file in the Finder, then by default it will open in Apple’s TextEdit. TextEdit doesn’t support comments or footnotes so you won’t see them there. You need to open the RTF file in a proper word processor such as Word or Nisus Writer (but not Pages, which has poor RTF support).

Aspose replied to me yesterday, incidentally, to confirm that they have reproduced the bug and added it to their list of fixes to make.

I am aghast! :open_mouth:

Whole time I was using Pages & Apple’s TextEdit, and those two are exactly what I shouldn’t have been using?!
I’ll be damned.

It would be nice if I knew those editors doesn’t support RTF properly.
I opened it with Google Docs and finally met with my pretty footnotes nested securely on the bottom of the page.
(Google Docs! Even this free & web software opens it correctly. Though, Pages and TextEdit are free, too, technically. Still shocking)

I’m terribly sorry for all the hassle for nothing.
Thank you very much for the kind replies, gr & KB.

No problem, this gets lots of people! To clarify, Pages supports footnotes and comments, and it can read .docx files beautifully, so footnote and comments in .docx files will come along into Pages. But Pages’ support for the RTF format is really basic, and Pages will not read footnotes or comments in RTF files.

Hopefully Aspose will have this fixed soon and I can include it in an update. They are usually pretty good about fixes, as I say - every bug I’ve reported to them has been fixed within a matter of weeks at the most.

Just to let you know that Aspose has now fixed this in their framework, so this will no longer be a problem in the next update of Scrivener.

All the best,