Compile to .docx - Strange punctuation formatting

I’m running version .29 on Windows 7 and compiling to .docx that I’m opening in Word 2010. When I compile, the font is set to Times New Roman. When I open the compiled file, all the letters are Times New Roman, and so is most of the punctuation, but some of the punctuation is set to Courier instead. In Scrivener everything is appearing as the same font (which I have set to Calibri).

My current workaround is to select all the text and change the font in Word after compile.

Which punctuation marks are coming out Courier?

It looks like apostrophes and quotation marks. It’s not all of them, just some of them, but there doesn’t seem to be a pattern to it, other than it’s 1-2 per printed page. Some of the text was pasted in to Scrivener, and some was written in Scrivener.

This happens to me too! I can’t tell if it’s all or just some, but definetly most of my apostrophes are in Courier New. I’m running Scriv .29 on Word 2007 on a XP.

I’ve also had this problem compiling to just a .doc format, also in Windows 2010. My document didn’t have any quotation marks, but wherever there is an apostrophe, it is in Courier New font.

Just an FYI, I’m still seeing this in 035. I can’t compile to .docx, but I’m seeing it in .doc.

I’m having the same problem in Word 2010 in Windows 7 (.RTF). All or at least most apostrophes and quotation marks are in Courier New (the font I used in Scrivener 035), even though I compiled the document in Times New Roman.

Forgot to add that it also happens with some accented foreign letters, such as some French or Turkish characters.

I saw the same problem w/ quotation & double quotation marks in .doc, .docx and .rtf.

Just to double-check, these are characters that you are able to produce in TNR (e.g. if you just typed them in Word using TNR, that font does support those characters)? I know that’s not the full problem here, since obviously smart quotes are supported, but I have a theory I’m working on about those and special accented characters might throw it way off. :wink:

Actually I didn’t produce the characters myself. They were part of EndNote in-text references (in EndNote code) in the original Word document originally formatted in TNR, which have been converted to Courier New when I imported them into Scrivener. I obviously lost the EndNote codes at that point. When I compiled the final document into TNR and exported to Word, all kinds of funny things happened to the words that had accented characters (especially Turkish ones). Part of the word would remain in Courier New and the characters themselves were replaced by various symbols. To answer your question, I don’t know if I could produce the Turkish characters because I never tried. But I could surely produce the French accented ‘e’ in TNR which was also altered in the process.

I’ve had this problem too. I’m compiling to .rtf. It happens in the first paragraph of a file, but not all files, just some. It happens with apostrophes (’) and smart quotes–so yeah, basic characters that are part of the font. I look at them in Scrivener and they’re definitely set to Times New Roman. But the .rtf compiled file puts them in Courier New and it’s VERY strange looking! The really wierd thing is that if I “doctor” the compiled document in Word, if I insert a paragraph above the strangely formatted paragraph, it picks up the strange formatting glitch and also puts apostrophes in Courier New, even though all the surrounding text is in Times New Roman.
I have all transformations turned off during the compile.
Best regards,

PS–I am running version .35

All right, it looks like this has to do with two things: whether or not transformations are set in compile and whether you open the compiled document in Word. If transformations are not on (so, for instance, you’re not converting smart quotes to straight quotes) and you open the compiled document in Word, the first paragraph of each document will use the factory default editor font for these characters. (Ignoring special accented characters for now, this applies to smart quotes/apostrophes, ellipses, and em-dashes.) Opening the same document in OpenOffice, however, the override font is correctly used. Likewise, if you do have transformations turned on for a given character, then that character will use the override font.

That’s just an update; Lee’s got the bug report and with luck it’ll be an easy fix for the next update.