Compile to rtf or Word, font and style issues

When I open a compiled document in MS Word I find that the text itself is set using the font selected for the compile. But when I select the paragraph mark in the file, it tells me Courier is used. This leads to issues with numbering, since it appears as if the number picks up the font used from the paragraph mark rather than from the text itself.

I experimented with the rtf file and changed the font declarations:

{\fonttbl{\f0\fnil\fprq2 Courier New;}{\f1\froman\fprq2 Times New Roman;}}


{\fonttbl{\f0\froman\fprq2 Times New Roman}{\f1\froman\fprq2 Times New Roman;}}

and now I can apply the numbered style of my Word template correctly.

I’m not sure if this is a bug or a feature… Should this be different/fixed in future versions?

Don’t know what’s goint on under the hood in Scrivener, but on the Word side you could:

  1. Open the Styles Pane [Shift+Ctrl+Alt+S]

  2. Klick Options and under “Select formatting to show as styles” select “Bulleted and numbering formatting”.

  3. Then you see those numbered entries as “Style Numbered (Latin) Courier New 12 pt …” in the pane.

  4. Click on the drop-down triangle and then “Select all instances”.

  5. Press [Ctrl+Spacebar] to remove all manually applied formatting in the whole text.

That should show the numbers in the default font. (Steps are for Word 2010, so YMMV.)

Of course, if you don’t have any other special formatting in your text (like italic) you could shorten this procedure

  1. Select all [Ctrl+A].

  2. Press [Ctrl+Spacebar] to remove all manually applied formatting.

PS: That kind of “fiddling around” in the compiled output made me a fan of the MultiMarkdown approach that’s also supported in Scrivener: plain text, formatting directly typed in, and rock solid.