compile, vertical spacing between paragraphs, printing

I’ve found a very odd bug that is making me nuts.
When I compile a portion of my novel manuscript to RTF or Word and then print it out, paragraphs occasionally overlap. Specifically, the bottom line of paragraph A and the top line of paragraph B are printed on the same ine, causing overlap of characters. It doesn’t happen on 100% of paragraphs, unfortunately. It’s one of those intermittent buzzards.
It has happened on two printers and mulitiple compiled files.
The only workaround I’ve discovered is selecting all the text and setting it all to double spaced. In a 25 chapter book this is problematical because the line spacing preceding the Chapter paragraph is single spaced and the page break doesn’t work right. That requires me going back in and making changes on each chapter.
Is there another workaround for this bug?
Is there a way to set the output formatting in a compile job?
Thanks for all the fabulous work, y’all,