Compile with both Folders and Text Docs

Hello!

I found Scrivener on the App store a few days ago, which led me to your website to download a free trial. Firstly, I must say how impressed I am with the software. The organization is gives me is just wonderful, and having all of the chapters of my work in one file makes organization a breeze!

Anyway I did have question, and if it’s been answered already, I’m sorry. I tried searching first, but…

Basically, I’m using both folders and regular text documents for chapters in my work. For example, Chapter 1 is a regular text file, Chapter 2 is a regular text file, whereas Chapter 3 is a folder, because the chapter itself is longer with multiple scenes. I’d like to have a page break between chapters and a space break between the scenes, but unfortunately it doesn’t seem to distinguish between the scenes within folders or the scenes themselves. Some chapters have five or six scenes within them and I don’t want a blank page between each one.

Is there a way to get scrivener to work differently with the files within the folders? I hope this made sense, it was kind of hard to describe.

There are a few ways I can think to do this, the most basic being to just tick “page break before” for all the relevant documents, either in the Content tab of the compile settings or in the meta-data section of the inspector for each of those documents. However, probably the way I would to do this would be to just convert your Chapter One and Chapter Two documents into folders. Folders in Scrivener are pretty nifty because they can be documents themselves, not just containers for other documents, but folders and documents can be treated differently when you compile–including how you separate them.

So suppose you set up your binder like this:

You can convert your current Chapter One and Chapter Two documents into folders just by selecting them in the binder, right-clicking, and choosing “Convert to Folder”. You’ll see their folder icons have a little superimposed paper icon in the bottom right, as in the image above, indicating that the folders themselves are also text documents. Since you don’t have separate scene documents for these folders, they’ll have no subdocuments. Chapter Three, however, has no document text as part of the folder, but it does contain several subdocument scenes. The Chapter Four folder I threw in just to round things out for the explanation.

When you’re ready to compile, click the triangle button to the right of the “Format As” drop-down in order to view the expanded settings. In the Contents pane, you’ll want all of your items checked to be included–all of the Chapter folders, including Chapter Three (even though it doesn’t have any text of its own), and the subdocuments. I’m setting it up this way so that you can assign chapter titles to the folders, since the way the binder is set up now, all chapters are folders–some have the chapter text as part of the folder and some have it broken into multiple scenes as subdocuments to the folder, but the folders themselves are the chapter divisions. Make sense? So in the Formatting tab of Compile, you can set it to include titles (the name in the binder) only for folders and to include text for both folders and documents like this:

That way you don’t also get the titles of your individual scenes, which I’m assuming you don’t want (though obviously it’s easy enough to tick the “title” checkbox for documents as well if you want them).

All right, so then to the major point: Click on the “Separators” tab and set it up like this:

That gives you just an empty line between scenes but a page break between chapters. The main thing to note here is that you have a single return between the folder and the text document; this is so that you get the same spacing between the title and the text as you do in the other chapters that have the text as part of the folder. If you actually have your binder set up so that the folder chapters that contain subdocuments also have text themselves, as the initial scene of the chapter, you’ll want to switch that to be an empty line, just like you have between the text documents.

Just to elaborate on MM’s first point, because that is by far the easiest: the standard novel format is set up to handle this situation, so all you really need to do is tick “Page break before” for chapters that are text documents. This is because the “Separators” pane in Compile is set up to insert a # character between text documents, treating them as scenes. By ticking “Page break before”, you tell Compile to start the chapter on a new page instead, which is what you want for chapters. All the rest of the formatting should be handled for you. The only other issue you would have is that if you have typed any # characters to separate scenes inside the single-text-document chapters, when compiled those hash characters would come out left-aligned because of the formatting being overridden by default. You could use “Preserve Formatting” (from the Format menu) on any hash tags you add yourself to avoid this, but I would instead recommend breaking down those chapters into scenes if you get to the point where you need hash characters between them (because then you can use other compile formats to compile it in different ways).

So, in short:

  1. All you need to do to fix your current problem is tick “Page break before” for chapter text documents. You can do this in the inspector or, if you forget, you can do this in the “Contents” pane of the Compile sheet.

  2. If you realise that some of those individual text document chapters would work better being split up into scenes, use the Documents > Split > at Selection (cmd-K) tool to split them up into several scene documents, then select all of the scene documents and use Documents > Group (opt-cmd-G) to group them all into a chapter document. This step is only needed if you want more than one scene in those chapters.

Another, possibly even simpler option is to have a folder with just a single scene document in it for those chapters currently stored in regular text documents (just select the text document and hit opt-cmd-G to enclose it in a folder). This saves you from remembering to tick “Page break before”, and it also means makes it easier to add extra scenes later when you’re revising if you decide these chapters need more than one scene.

I hope we haven’t made it sound more complicated than it is - if this does sound complicated, just stick to (1), ticking “Page break before” for text document chapters, for now, as that will do the trick - everything else is just a suggestion for going forward.

Hope this helps.

All the best,
Keith

Thank you both very much for your swift and detailed answers! I figured that there was an easy way to fix this, I just couldn’t find it anywhere. I’m bookmarking this page for sure!