Compiled reading errors for TTS

I am having trouble with words being pronounced wrong (wrong word) with TTS in Android, probably other systems too. For example, my document when compiled for PDF, it says the word Staff as ‘Santa’, yet the same document compiled as an EPUB file says the word Staff as ‘Staff’, both of these are using Google TTS software. I tried the PDF using Acrobat Read Aloud and that once again says the word ‘Staff’ as ‘Santa.’ Google assures me it is not their software, but must be when the document is being compiled as a PDF.

I am creating a 2000 page, 2GB Document for the Onyx Boox Lumi and I really need this to read the documents correctly. Any suggestions what is causing this? 99 percent of the document reads fine, just select words.

Thank you.

I found out that these are errors caused by Scrivener. Somehow, the formatting of the text file is causing issues when creating the PDF’s. When using speech in Scrivener it pronounces the words fine, as it does when creating an ePub file.

At the moment the only solution I have is to create a new text file, then manually type everything in from scratch, then reformat it, because if I use copy and paste, it has the same issue.

I have tried removing the formatting by selecting all characters, then selecting ‘No Style’ then changing things back, but this does not help either. So how can I remove all the formatting in the file so I do not have to re type everything back in.

Thanks, Simon

Well, if anyone is interested I know what the problem is. It seems that for some reason, Scrivener does not like converting the Bookerly font.

To fix it, I chose the text file, pressed ‘Control + A’, the selected ‘No Style.’ I then Changed all text to Georgia font, and then everything seemed to work fine.

If someone can please request that the compiling of the Bookerly font be looked into, it would be great, as it is a nice font for eReaders, more-so since Google has has added a hole lot of natural voices to its TTS engine for android.

1 Like