'Compiled view' blank when clicking on project item


I’ve noticed that often when I click on the top project item, the ‘Compiled view’ (i.e., all of my sub items displayed in one continuous screen) is blank. If I click on Corkboard View, then back on Show Text View, Scrivener will then correctly display the compiled text of all of the sub items.



I don’t have my VM open right now to double-check this with the beta, but I’m pretty sure it works similarly to the Mac version in this regard: the “Scrivenings” button in the pill box in the menu toggles between the group mode you’re looking for and single document in cases where either can be viewed. Since folders can themselves contain text (not just containing subdocuments with text), what’s probably happening is that you’re clicking the folder and it’s showing you the empty document that is that folder, rather than the subdocuments under it. You should be able to just click the Scrivenings icon to display the group of documents without having to jump to the other buttons first.

The Mac version will remember your settings for the editor, so once you’ve set it to display the folder subdocuments as a group session it will default to doing that when you move around in the binder, but I don’t know if that’s true at the moment of the Windows version or not; you’d have to test it out.


As far as I can experience this myself, Windows (Win7 at least) does remember these settings indeed.

Nevertheless, I found it confusing myself.
I could overcome this easily by getting used to the toggle command on keyboard CTRL+1.

This is still happening to me, although I’m finding it hard to predictably reproduce.

It seems to hinge on the ‘Show Text View’ ‘mode’. When looking at a scene, the button for ‘Show Text View’ displays a single document icon. When looking at the Short Story parent, it shows what looks like a multiple document icon; which makes sense, since this would be collating multiple documents together for a single view.

However, for some reason, sometimes when I click on the Short Story parent, the button displays the single document icon, and the text area where I should be able to scroll through a collated view of all the sub documents is empty, grey and uneditable. If I click on the ‘Show Text View’ button at this point, the icon changes to multiple documents, and Scrivener shows me the collated view of all of my sub documents.

It’s the fact that this isn’t predictable (always show multiple sub document view when clicking on Short Story item in the tree; or, always show single document view when clicking on Short Story item in the tree) that makes me think this is a bug of some sort.


Can someone try the following steps to see if it reproduces the behaviour elsewhere?

[] Click on ‘First Page Header’ item in binder[/]
[] Click on ‘Show Corkboard View’ button[/]
[] Click on another sub item in the binder[/]
[] Click bank on ‘First Page Header’ (which should be in Corkboard View) and click on the ‘Show Text View’ button – you should now see your first page details with name / address etc[/]
[] Click on the ‘Short Story’ header[/]

On my machine, this seems to predictably put the Short Story item into a blank, grey, uneditable state. Clicking on the ‘Show Text View’ button should now correctly display the collated sub items view.

I can can confirm this behaviour on my vista laptop using the short story template.