Compiler appears to be skipping folders marked to be compiled

There are two issues here that may be related but I will keep the separate as the second may involve some user error.

First - final folders not compiling:
When I went to compile recently in the windows version I was surprised to find two whole chapters missing from the end. I checked that those two chapters were supposed to be included in the compile and could find nothing wrong. I then did a compile under a supplied format rather than the custom one I typically use and the same thing happened.

Upon some messing around with a dummy file as a template I managed to find a fix to the issue that meant including two blank folders after the final chapters would mean that all the actual real chapters would compile. I’ve attached a picture of what I did.

The green chapters were not being compiled, the red circle indicates the two blank folders I added to the project to get those last chapters to compile. Yes the blank folders were marked for compile. So in theory they should have compiled. I didn’t have any filters on that might interrupt the compile, I checked all the settings. I could find no reason why the last two folders wouldn’t be included in the compile.

Second related issue - Back Matter.
So I’m going to admit some user error might be involved here since I don’t typically use back matter just do it all through the manuscript. So I would normally have a final “folder” with “scenes” in it for the glossary. This time I decided to put it in back matter since the glossary didn’t need to be included.

While I was exploring the first issue of the final two folders not compiling I added the back matter to the compile and discovered that it can count as 1 folder. However even with the fix from above the text in the glossary never showed up in the compiled document. I checked the compiler and it was defaulting to “front matter format” so I changed it to “back matter” and this was how I discovered that the back matter could count as the one folder. Also from the image I posted I tried to add the BLANK folders to the glossary too in hopes of it fixing the issue. The result was that one of the blank folders in manuscript was compiled as a part heading and the glossary text still didn’t compile. So the back matter appears to be able to function one of blank folders I included, but it doesn’t seem to matter how many blank folders or scenes I include in those folders the glossary still doesn’t show up in the compile.

Obviously the easy fix for this would be to move the glossary back into the manuscript area and add two blank folders after it to ensure compile.

I’m not really sure what is going on in either of these issues. Everything is marked to compile it just seems to want to stop short by two folders when I do.

The most likely issue is that you have a filter set in the Contents pane of the main Compile screen.

The second most likely issue is that you’ve inadvertently assigned a different Section Type to the missing files.

So, how do you find out what filters are set and then, how do you remove them?

There’s a little funnel icon to the right of the dropdown menu at the top of the contents list. Click that.

I’ve tried to reproduce these conditions, as provided in the screenshot, but I haven’t been able to see the described dropping of sections from the output. In the sample project, I also create a similar glossary in a back matter folder, but I never got around to testing that since I couldn’t reproduce the initial condition either.

Have a look at this, and see if there is something I should be doing different in order to see this. I’m using the basic “Enumerated Outline” compile format for its brevity. (177.2 KB)