Compiler headaches

I’ve been battling compiler for several hours and things are ALMOST okay now but (and I’m sure it’s my fault for not understanding the instructions) it’s driving me buggy. I’m using the Times 12 point w bolder titles compiler format and for the life of me I can’t figure out how to keep the title “Chapter 1” (etc) from not having a page all of its own. I’ve tried several different configurations, but the compiler INSISTS on putting a page break between the chapter number and the page text itself.

I’m compiling for Word docs, btw. Also, I really don’t want the editor to see the ugly blue “page break” lines either if possible. Any clue how to shut that off? I’ve tried just deleting the extra page breaks too, in my Word doc (in Open Office) but I can’t seem to remove them there either.

Thanks!

This sounds like it might be a bug, which Lee is fixing for the next release. Currently, if a document is set so that there should be a page break before it and only the title of the document is compiled and if there is no page padding for that document (i.e. extra lines added to the top so the title starts partway down the page), then a page break is incorrectly inserted after the title as well as before. If this is what’s happening, you can work around it a couple ways until the next beta is out which should fix it:

  • Add a blank space or carriage return to the document’s text (you’ll probably want to adjust the title suffix or the line spacing in this case so that you don’t end up with too many extra lines)

  • Add some page padding for the document type in the Formatting tab of Compile (click “Modify” to add it)

  • Remove the page break separator and instead use a custom tag that you can then do a quick Find/Replace on in Word to swap for the page break there

As far as the blue page break line, that’s only seen if you’ve turned on the “Show Invisibles” option for whatever program you’re using–in Scrivener it’s Format > Options > Show Invisibles; in Word it’s in the options for displaying non-printing characters (the default toolbar should have a little paragraph symbol button that will toggle it easily). So whether or not your editor sees it would depend on whether she had her program set to view these characters.