Compiling a mobi file fails

I have a problem with compiling a project as a Mobi ebook. It used to work but then I fiddled with the settings because I had a problem with a page not appearing in the right page. When I now try to compile, it fails. The error log says:

Warning(prcgen):W14001: Hyperlink not resolved: /private/var/folders/2s/h93zxwxs1j15t135p575nyjr0000gn/T/EBOOK_TEMP-16/Quirky Christmas Stories TEST/body26.xhtml
Warning(prcgen):W14002: Some hyperlinks could not be resolved.
Info(prcgen):I1008: Resolving start reading location
Error(prcgen):E24010: Hyperlink not resolved in toc (One possible reason can be that the link points to a tag with style display:none):/private/var/folders/2s/h93zxwxs1j15t135p575nyjr0000gn/T/EBOOK_TEMP-16/Quirky Christmas Stories TEST/body26.xhtml#
Error(prcgen):E24001: The table of content could not be built.
Info(prcgen):I1016: Building enhanced PRC file
Info(prcgen):I1007: Resolving mediaidlinks
Info(prcgen):I1011: Writing mediaidlinks
Info(prcgen):I1009: Resolving guide items
Info(prcgen):I1038: MOBI file could not be generated because of errors!

.However, this happens even if I try to compile without a front and back matter folder! I realise it must be something to do with the table of contents but I’ve no idea what I’ve done wrong or how to resolve it. I’m
starting to think that the only way round is to try to compile it as an epub file and then convert.

Can anybody help please?

What version of Scrivener do you have?

If it’s a version of Scrivener 3 other than 3.1.2, please update to make sure you’re not dealing with any previously fixed bugs.


Thanks for this. I’ve just checked and I have the previous version 3.1.1 so I’ll update to the latest one and see what happens. It was working to begin with though.

Hi, I’ve just updated my version of Scrivener to the latest one but sad to say, I still get the same result. Still saying hyperlinks could not be resolved and mobi file could not be built because of errors.