Compiling - am I mentally challenged or what?

Okay, so I’ve been using Scrivener for three, count 'em, three novels already, and I always have the same problem. By the time I’m done, I completely forget how to compile correctly.

NOW, that I’ve updated/upgraded, I’m completely lost.

I’m working on a little book proposal. I set up my usual personal makeshift novel template. It’s a little different from my older makeshift novel template but I was a bit impatient and just slapped something together to get a 10 page writing sample out the door.

Somewhere around the spot I call “Act I” (folder underneath “Manuscript”), “Chapter 3” (third folder underneath the “Act I” folder), I have a few-thousand words of text I’m trying to compile and print out in a Word doc and proofread.

I’ve tried compiling every which way. I’ve tried reading (albeit, skimming hastily) the quite complicated (for me, a la mo) tutorial page. I’ve looked for a video tutorial thinking that may be the easiest thing to absorb at this late hour. But I can’t seem to figure it out.

I check EVERYTHING on the compile page…nothing…somethings…override…don’t override… And still, my text is nowhere to be found. Just forty-five pages with the word “Chapter” in the center.

Is there a compile cheat sheet? Cliff Notes? An easy answer for a tired writer?

Beyond that, is there something a little more comprehensive to help me compile intelligently? I don’t care if i have to ultimately go into a Word doc and futz with a header or delete a bunch of empty “chapter” pages. I simply want the words I’ve written to appear, in some way, in the compiled document.

Help?

A couple of suggestions, borne of extensive trial and error on my part, in case you haven’t tried them.

  1. In the formatting tab, you need to make sure the tick box in the ‘text’ column is selected to print for the level you want to print out. The single sheet of paper icons show documents that are just documents; multiple sheets of paper icon show documents with subdocuments; and folders are documents that are folder.

  2. Delete all but ‘Level One’ for each of these types (folder, document-as-folder, and document). That means the settings for Level One will apply to to every folder, document-as-folder and document. It’s just simpler.

  3. There’s a checkbox in one of the other tabs about ignoring levels outside the selected folder. Check this, as it means Scrivener won’t be trying to apply formatting for what it thinks are subfolders, and what you think of as the base levels.

  4. Make sure you’ve selected the right folder for your content in the drop down box at the top left, and everything you want to compile is ticked to ‘include’.

Hopefully it’ll be one of those…

Okay–

Thank you, spinningdoc!

So that worked, in that I seemed to have happened upon my text somewhere in there without comprehending why. It re-formatted everything to an odd font (Optima maybe?), but at least it’s a step in the right direction. So—I’ve managed to extract my text and with a lot of tweaks, I’ll be able to get it to look right, but can someone explain a simple solution?

Layers and layers and subfolders and subdocuments? I understand that lots of people want to create much more complex documents than I do but it’s obvious that I need a place to go for very clear (duh) instruction. “Setting up” Compiling is always where it all breaks down for me.

Is there a video tutorial or a “if you want to do it really simply, here it is…” instruction? I can never seem to make it successfully through the tutorial because I get incredibly confused.

Any advice on setting up and compiling a super simple structure? Even the templates are a little difficult for me to “get” when it comes to compiling.

Here’s how I work: I leave all the “fancy” typography/spacing stuff for the final Word document. Other than text and a super-simple title page (“My Cool Book Title…by Me”) I write the word “Chapter” at the top of each Chapter folder, a few spaces, and begin to type. Usually in Century Schoolbook font unless I’m in another-font-mood.

Aside from the “extras” at the bottom, my manuscript/binder usually looks something like the following:

Manuscript
Title page
ACT I [folder]
CHAPTER [folder]
CHAPTER [folder]
CHAPTER [folder]
CHAPTER [folder]

ACT II [folder]
CHAPTER [folder]
CHAPTER [folder]
CHAPTER [folder]
CHAPTER [folder]
etc…

ACT III [folder]
CHAPTER [folder]
CHAPTER [folder]
CHAPTER [folder]
CHAPTER [folder]

Any really simple, step-by-step how to for me somewhere?

Thanks again!
Jennifer

If you put everything structural (and by that I mean chapter headings and scene breaks) into the text editor itself while writing, you might just be fine collapsing the Compiler complexity by clicking that little up arrow button on the right side, choosing the “Original” preset, RTF for your format, and punch the button. :slight_smile:

This basically does nothing but the basics. It puts all of your pieces together into a single RTF file, changes no fonts, adds no headers, doesn’t convert italics to underlines—just what you wrote.

And, if you do want to branch out a bit and try a compiler option here or there, it’s much easier to start with Original, than one of the other presets—some of which are fairly involved.

Thanks!–I tried that and got a nice RTF file (with my text in it!), which when I saved as Word—completely looked terrible. Single spacing…etc…

Good for now, but—

Since I am a full-time author/novelist, writing more than one book and many proposals a year, I’d like to comprehend how to do it…albeit, simply. Your suggestion works, AmberV, but seems like it might not be best for the longer term.

Is there a simple way for me to compile? (It seemed to me to be simpler in my older version of Scrivener??)

I’m not completely dumb when it comes to computer-y stuff but I’m not completely proficient either. Can I do a (simple) tutorial that would help me? Follow some step-by-step instruction? Get a short phone consult? I am a simple user with a low capacity for learning and retaining the tricky stuff but Scrivener is now my go-to application for my entire professional existence.

As I said–I tend to set up my binder as shown and COULD put everything “structural” I need into the text editor if that’s easiest. (I do want to maintain things like italicized words or bold, etc).

Help available?

In that case, try the “Times 12pt with Bold Folder Titles” setting. After selecting it, click on the Formatting pane. You’ll see that the “Folder Level 1+” row has “Title” checked. Uncheck that, and give that a whirl.

If your title fonts are getting mangled, make sure these folders are set to Compile As-Is, which is similar to the old Preserve Formatting. If you have everything in one document though, that might complicate things. By that I mean, you printed “CHAPTER [folder]” above, which to me implies you book the scene text into files beneath it, but you also stated your workflow as kind of just, typing in the title and then typing in the chapter, as though you were in one document. So if the document as the chapter title in it, then they cannot be treated separately as easily—and I’m not sure how you did this in Scrivener 1.x for that matter, either, as it worked the same way. Either everything became one font, or it didn’t, unless you had one document with nothing in it put the chapter title text, and “Preserve Formatting” (now “Compile As-Is”) turned on for it.

Now, there is an additional tool. You could select the title in the editor, and use the Format/Formatting/Preserve Formatting feature to block out that section of text as “protected” from the compiler’s formatting function. Here is an example of what such a document would look like:

That blue stuff is the preserve formatting block.

Amber

Compiling is really powerful, and walking the line between a massive, complicated bit of UI and keeping it simple is very tricky - it’s setting up a database report, effectively. I know having used Access and a few other db’s helped me get my head round it. Maybe a couple of case studies in the manual would help - I know it takes me a lot of trial and error to create get new Compiles how I want them.

I’d be happy to help out with some testing, reviewing, etc.

Thanks for the feedback, it’s definitely something I had in mind, but just hadn’t had time to do yet. I think more built-in presets will help, too. Like in this case, having an alternate with no titles would have probably helped, even though it’s just one checkbox, the things you have to learn to find that checkbox and know what to do with it are quite a bit more than just pulling down a menu.

I’ve written several novels with wonderful Scrivener, but I have never been able to get a decent Word doc using compile.

I’m afraid all I do now is copy and paste into Word. Usually chapter by chapter.

It’s a bore, but it’s the only way I don’t get a Word doc full of nasties, many of which simply cannot thereafter be removed - not by me, not by the techies at my publisher.

I blame Word rather than Scrivener; I hate Word with a deadly passion, but it’s the format in which I have to deliver my books, and so…

PS I should add that I’ve always assumed it’s because I’m too dim to get my skull round the instructions for compiling - I really don’t understand them, and however many times I tried, I never got it to work.

Amber

A sticky for posting useful Compile settings files would help, too.

Thanks!

This seems to be working as an easy-to-get way to get things done.

A couple things I played with that maybe you could explain. Checking the “override text” box seemed to smooth out what was looking like some funky spacing in my Scrivener doc. BUT the font went to Optima—not a favorite font. I’d be happy to have just about anything I’m working on in Century Schoolbook or even Times. Did I set something wrong somewhere along the line or is simply the original template at work?

So now…for my long term solution - should I work with a “novel” template or just build my own and use it? I like some of the “extras” in the novel templates and wouldn;t mind trying them out. That said, I’ve developed most of my own “extras” and have been fine with them.

So - from “Open” to “Compile” - do you have a recommendation? I’m in no rush for the answer, it’s just so helpful to have someone walk me through it (then I have the instructions to look back on at anytime!)

Thanks again for your help,
Jennifer

I think, as someone who has used Scrivener to write three books already, you might not get a whole lot from the templates beyond what you’ve developed for yourself. You could of course easily open up one of these templates and drag anything interesting over to your project. Since templates are just starter projects, all of the stuff in them is stuff you can copy and merge together for your own use.

I’m uncomfortable answering “should I” type questions. :slight_smile: I would rather say Scrivener doesn’t want to be a “you should do this” program, but rather a, “I like to work this way and it lets me work that way” program. Could you use a template instead of what you’ve been doing? Sure. Is that better? Only if it is more comfortable for you. If using styled text headers in the editor is more comfortable and useful to you as a writer—then do it! Scrivener supports working that way. If you think maybe just letting Scrivener handle the title generation and typesetting during compile might be easier—sure, go for it, it has a lot of tools for doing that as well, such as adding "Chapter #: " in front of all the real titles. Do what works for you. I could tell you how I like to work myself, but it probably wouldn’t suit you, and how I work is just another equally valid way to use Scrivener. Your way is no better or worse than mine so long as we both keep writing.

Regarding Optima: if you see Optima in the formatting preview area of that pane, then that is what you will get. Make sure the entire thing is set to the font you prefer. If all you are exporting is text, this should be easy to do as there is only one element to format. But, if you had selected the 12pt Times preset that I indicated above, it should have already been Times. Maybe you don’t have Times installed on your computer? Well, again, just check that box and set it up the way you want the book to look. That’s all it does! Play with the ruler and font stuff just as you would in a regular text editor.

So…oh, gosh, here I am finishing another novel and hopelessly lost with the compile feature. I have exported to an RTF (which I guess I will then copy into a Word doc??

My nice text formatting, which looked great in my Scriverner doc, is now (like my problem 2 years ago!) all in Optima font with no formatting whatsoever (no paragraph indents, no italics etc).

Amber indicated ages ago that there was some sort of button I could press that to at least get it all into Times but I don’t know where that is. I like to type in Century Schoolbook, but I’m completely lost on how to get that – i’ll settle for Times!

Can you PLEASE give me a dumb-dumb, screenshot by screenshot, way to compile…again?? I will the, I guess, get my comments in that RTF/Word doc with my agent…then re-IMPORT into Scrivener, then RE-COMPILE into an RTF!!!

Eeeks. In any case, please - can someone go over this again with me. If I didn’t adore writing in Scrivener so much, I’d probably give up at the compile stage because I always get hooked up here.

My manuscript is set up as I’ve indicated before. I’m going to enclose a few screen shots so you get the idea what’s happening.
Screen Shot 2012-05-11 at 4.44.41 PM.png


Screen Shot 2012-05-11 at 4.43.22 PM.png

All right, here’s a start–once you’ve tried this you can see how close it is to what you’re looking for and we can tweak from there.

Open File > Compile and click the “All Options” button at the top if it’s not already selected. This will expand the window so you’ll see the sidebar of options (Contents, Separators, etc.). Your screenshot shows this already selected, but I’m including this step for the sake of being thorough.

Click the “Format As” pop-up menu at the top and scroll down to the bottom to select “Manage Compile Format Presets”.

This will bring up a window listing all the built-in compile presets available and will also show you any custom ones you’ve created or imported. It’s alphabetical, so scroll down to find “Times 12pt with Bold Folder Titles” and tick the check box.

Click “OK” to close that window. Now you can click on the “Format As” pop-up again and you should see “Times 12pt with Bold Folder Titles” among the options listed under “Predefined Formats” in the top section. Select that.

This will give you Times New Roman font, double spaced lines, indented first lines. It will leave in place any italics you used when writing. It will also include the folder titles, as you see them in the binder. Going by your previous time through this, I think you may not want these: if you have the chapter title written directly in the document along with the chapter text itself, you won’t want to duplicate that by also including the folder title. To remove the folder title, select “Formatting” from the left sidebar and then deselect the “Title” column checkbox in the Folder row.

Now, assuming that you did put your chapter title directly in the document, I will further assume that you also centered it and would like to keep it centered. To do that, click the “Options” button in that same Formatting pane of Compile and then check the box midway down to “Preserve Alignment”. You may want to also then check “Centered text only” to make sure everything else gets cleaned up, or you might prefer to leave that unchecked if you intentionally have right-aligned text within your manuscript.

Finally, since your Title Page is most likely set to compile as-is and you mention that you’ve used a different font when drafting, select the “Quick Font Override” from the list on the left. Choose “Times New Roman” from the pop-up menu and check the box to enable the override. This will ensure that the Title Page uses TNR for the font as well, since it is otherwise compiling “as-is” and not having its formatting overridden by the settings applied in the Formatting pane.

That should take care of most of what you’re after, but give it a try and see how you like the results. If you you don’t like the way the chapter titles are coming out, you may want to try selecting them in the editor and then applying Format > Formatting > Preserve Formatting, as Ioa mentioned up-thread: this will preserve your editor formatting, as the name implies, so the settings from the compile formatting pane (line spacing, font size, etc.) won’t affect it. It does mean though that if you’re using Century Schoolbook there, they will compile as Century Schoolbook even though the rest of the manuscript will be in Times New Roman–the Quick Font Override won’t affect that. You can however go back to the “Options” in the Formatting pane of compile and check the box in the bottom section for “Preserve Style only preserves” and then tick all the boxes below that which you want to apply: in this case, probably all of them, which will allow most of your formatting for the titles to remain while still using the compile settings for the actual font.

Alternatively of course you could switch your Quick Font Override to Century Schoolbook and compile everything in that instead of Times. :slight_smile:

Anyway, give it a try and then report back on where you’re at and where you’d like to be. Details on what you’re getting compared to what you’re trying to achieve will help figure out where we need to alter the set up.

Thank you for that extremely patient and thorough explanation. I think (at least this time) I have something working. I’m going to include my screen shots mostly so I can reference them next time I’m dumbfounded and trying to decipher my ‘past’ posts on the subject.

This seems to work…for now!
Screen Shot 2012-05-16 at 6.56.24 PM.png
Screen Shot 2012-05-16 at 6.56.01 PM.png

Didn’t even have to ask THE EXACT SAME QUESTION again! Just looked back at the answers from last time. Thanks again. So very thorough and easy to follow. Great to have this to refer back to!

Excellent! And congrats on another novel! :slight_smile: