Compiling and "skipping over" folders in hierarchy

Okay, I feel like this ought to be simple, but I’ve read all the instructions and played with things and still have trouble. I’m hoping someone can point me towards the obvious thing that I’m missing!

So, what I’m doing is this:

I have my novel in two books, and I’ve organised my files like this:

Draft
–>Book One (folder)
–>-->Location X (folder)
–>-->–>Chapter (folder)
–>-->–>-->text files with scenes
–>-->–>Chapter (folder)
–>-->–>-->text files with scenes
etc…
–>-->Location Y (folder)
–>-->–>Chapter (folder)
–>-->–>-->text files with scenes
–>-->–>Chapter (folder)
–>-->–>-->text files with scenes
etc…
–>Book Two (folder)
…same format

I did this because it is easier for me to think about my chapters as the characters move between locations, but the locations are not meant to be part of the output. So, what I’m trying to do now, is just compile Book One with chapter numbers in manuscript format.

This is what I’ve tried:
I started with the Novel pre-set and modified it.
Under Contents, I select the folder Book One in the drop down menu for compiling. I unchecked the folders “Book One” and every location folder from the the include column.

Under Formatting, I made folders Level 1 and Level 2 to have no checks and nothing in “title formatting”, then put folder Level 3+ with no checks and Chapter <$t> in the Prefix box under Title Settings. I then went down to Level 4+ for text files and this is the only one I checked to include the Text.

I tried compiling like this, and I got:
It started with “CHAPTER TWO” and then had an extra blank page before each chapter that started a new location.

I went to Processing options and checked “Compile ignoring levels outside of the current compile group”. This changed the numbering such that it started with CHAPTER ONE, but the extra blank pages were still there (and this still mystifies me: shouldn’t what I said for Level 2 now be Level 3? But in the contents it does show Book One as a folder, which it also does if I choose Draft, so maybe that makes sense?)

I then played around with the Seperators, putting blank lines and such between pairs of folders, but this had no effect on the extra blank page (and I wouldn’t think it should – as there aren’t two folders in a row in the compile, since I’ve de-selected the location folders).

Can anyone help me get rid of the extra blank pages between chapters in different locations?

Have you checked your settings in the Contents pane of the Compile options? There’s a column of check boxs for “page break before” and I believe the Novel standard settings include this checked on some (all?) folders as a way to divide chapters, but since you’ve modified your settings this might be producing funny results.

I’m trying to see what you’re getting but so far I haven’t quite gotten it I think. When you say “extra blank page” you mean a full empty page inserted between chapters? Or just that the “Chapter X” is on its own page? For the second, you can uncheck the boxes for “page break before” from the Contents pane and adjust the separators to not insert page breaks. (So for instance, check “page break before” for the Chapter folder, so you start the chapter on new page, but then leave it unchecked for all the scene text files, and set the folder/text separator to just an empty line.) Not sure that’s really what you’re describing though.

What file type are you compiling to, by the way?

There aren’t any boxes checked in the Pg Break Before column in contents. What I’m getting is a full blank page between the chapters. I’m compiling to Rich Text.

All right, still working on this. Maybe you got it fixed in the meanwhile, but if not, my latest idea is to check your actual text documents for the page-break character. I can’t imagine how you’d have accidentally included this, but I’m sure there are ways, and at this point it’s the only way I’ve managed to reproduce what you’re describing; otherwise, setting up a project the way you’ve detailed, my text compiles without these blank pages.

Easiest way to check for the page-breaks: In the editor, choose Format>Options>Show Invisibles. Create a new blank document somewhere and in that choose Edit>Insert>Page Break. You should see a light blue vertical line in the editor. Select that (it will select the whole line) and copy it, then paste it into the search bar at the top right. Make sure it’s searching your whole draft, and see if it comes up with any documents in your book. If it pulls anything up in the search results, you can look through them and delete the page-break.

Any luck?

Ahah! Thanks! It wasn’t page breaks, but for some reason each text file at the end of a location ended with about 20-30 carriage returns (enough to fill a blank page, I suppose). Not sure how that happened (maybe I hit return while thinking???). I searched and replaced two carriage returns with one until it stopped finding them together.

Thanks for the pointer! And glad to know I did use the compile correctly…

Ahh, phew. Yes, your compile settings looked fine; I was pulling hair out trying to find something queer that was giving you the extra breaks. :slight_smile: You can’t even accidentally combine page breaks in compile to end up with a blank page, so all I could figure was something with the actual files. Glad it’s fixed!