Compiling creates strange format

I don’t know if this is a bug or if I’m doing something wrong. I’m using the latest beta.

I click the compile button and try to create a manuscript of the entire novel. The resulting file, when viewed in Word 2007, runs the words off the right hand side of the page. Adjusting the margins in Word has no effect.

I’ve tried this in three different formats (Custom, Novel Standard and Times New Roman) and saved it to both .rtf and .docx formations, with the same results every time.

Anyone else run into this?

Is the right hand margin set in Scrivener itself? You can set margins by using ruler.

No, and that’s really strange. Why would there be no right margin?

Going through the various sections, some have it, most don’t. Is there a way to add it to all of them at once? I’ve tried highlighting several sections and editing them at once but the margins remain different for each section.

To change the right hand margin for multiple files go to Edit > Options and select the editor tab. Change the right hand margin using the ruler then click ok.

Select the documents whose margins you wish to change in the binder. Click Documents > Convert to Default Style. When window pops up select the options you wish to use. That should change your margins.

I tried that. I checked “Preserve Font Style” and it didn’t add margins, or do anything else I could see. So I tired it again, checking nothing. I had everything in Times New Roman. It added the margins, but in the process set the font style to Veranda and removed all the bold and Italics.

This really sucks.

And I’ve never been able to find any place where i can set the default font to anything other than Veranda. Where do I do that?

In the same Edit>Options>Editor panel you just were using, where there’s a very nice model for both setting and seeing what the results are. Just above the ruler, there is a complete set of character and line formatting selectors.

I was looking for the dropdown box that appears in the sections. Found it under the “A.” The interface should be more consistent.

Is there a way to set the default right margin more than 5 inches? That’s as far as you can get on the ruler and it doesn’t scroll.

It does that to me too, though not on every chapter. Every now and again, one of the chapters will run off the edge of the page. That or the margin will be about half an inch from the left hand margin so there’s literally only half an inch of text on each line which amounts to about one word or so per line.

I’ve had the same problem. Not all the scenes, but it looks to be the ones that I originally pasted in from elsewhere in Scrivener.

Yeah, I’ve noticed that some of the documents in the templates don’t have the right margin properly set, so using them or duplicating them will produce the same issue (I’ve only ever seen it produce about a half-inch of text, being way too far to the left, rather than running off the page, but it’s presumably a related issue). I made a note of it, so it’s something that should get fixed once the templates are revised for the Windows release. Meanwhile you should be able to fix the margin in your word processor after export by selecting all the text and fixing the right indent.

I just wanted to add a discovery to this. I had a scene that was running off the page in Word. I thought I would try pasting it into a new file to see if that fixed it. It didn’t. But in the process, I discovered that in the files with the problem, there isn’t a right margin triangle. It does appear to be related to pasting. I had two scenes I merged into one. Scene 1 didn’t have the problem. Scene 2 did, and the margin triangle started where I pasted the scene in.

Hi Garridan,

Thanks for the extra tip. I do have the missing right indent written up as part of the bug report–this is also related to what program you use to open the files (naturally, both Word and WordPad get this). The point about the pasting though is quite good to know and I’ll make sure that gets in there as well. This seems related at least in part to setting the formatting options, so I suspect that the formatting that comes in through the paste may be triggering the bug–unless you used “Paste and Match Style” in which case you shouldn’t have brought in any formatting from the outside. Do you happen to know which you used? I’ll run some tests with this later either way, but every detail helps!

I tried Paste Style to see if I could get the page formatted right – didn’t make a difference. In Word, I can go all the way down to a 25% view to correct the formatting on that end, but there doesn’t appear to be any way to correct it in Scrivener, other than to fix it on the Word end.

I’m also puzzled by why it’s occurring. All of my scenes were pasted in from Word, but I only get the margin problem on two. Plus, I actually had a different margin problem when I bring it in from Word – the margins default to about half the screen. Paste Style didn’t work to fix this either.