Compiling for Kindle: How to insert Scene Separator?

I had a post a few months back asking how to remove the Scene Separator. Mission accomplished!

Now that my book is finished, I have decided I want to use # or * as a Scene Separator. I have just spent the better part of three hours trying to accomplish what I thought would be a 10 second task.

The attached screen shot shows my settings. This gets me a blank space (empty line between scenes but no #). macOS 14 with Scrivener 3.0.3.

Any advice?

It’s difficult to help without more information. According to your settings, you will get a # between scenes in the following circumstances:

  1. Your scenes are all in separate documents.

  2. Those documents are using a section type that is assigned the “Section Text” layout in “Assign Section Layouts”.

We’d need to know more about how your project is set up to help further, i.e.:

  • Which Section Layout are your scene documents set to use?
  • Are you scenes in separate documents, or are they in the same documents with a blank line between them in the editor?

Apologies. Yes, scenes are in separate documents within folders (named 1, 2, 3, etc.)

Section Type is set to "Scene for the scene documents.

Hmm, and in “Assign Section Layouts” the layout associated with the “Scene” type has the hash tags in it? Would it be possible to zip up and attach a sample project showing this, or to email it to us at AT literatureandlatte DOT com. I’m pretty sure it will be something simple but I’m a bit confused as to what is going on at the moment!

Thank you. It was something simple but not intuitive to me. I read what you posted and thought about it. I finally found the “Assign Section Layouts” and associated the "Scene"s with the one with has tags. It was on the “As-is” option. Thank you!

That would do it. A good tip is to pay attention to that central white preview column in Compile. Above each square in it is the name of the section types that will be affected by the square, so you can see exactly how they will be formatted.

Glad you got it sorted, anyhow!

All the best,