Compiling for the Kindle

I have been experimenting with the compile parameters along the lines of the video tutorial. I have not been completely successful yet. I think I am getting some confusion with ‘styles’ but my main issue is that I want to reset some parameters before I do another compile. However when I opt for ‘compile’ from the file menu I get this window…

Click for large view - Uploaded with Skitch

…which does not give me the opportunity to make any changes to my kindle compile parameters. Am I missing something?

Sorry, forget it. I just found out where the parameters are!

Glad you figured it out!

(For anyone coming across this thread looking for the answer, you need to click on the downward-pointing expansion arrow on the right of the “Format As” pop-up button to show all the options.)


Thanks Keith
Perhaps I can add a question about the compiling parameters.
I have created my book as a series of separate documents so I have no folders or containers. Each document is a chapter and the name of that document is the title to that chapter. I also have some sub-headings for sections within the single documents. I have compiled the draft so that I can do some copy reading on my kindle and that is working very well. However after each ‘title’ in the kindle version I am getting the word ‘text’ before the body text begins. I can’t work out how to remove this, can you help?

It sounds like you have the option checked to include subtitles between text elements–are you compiling notes, synopses, or meta-data as well as the titles and text?

In the compile pane under formatting, click the “options” button at the top in the “override text and notes formatting” bar and see if under layout options there the first box is checked. If so, unchecking it should get rid of the “text” marker, but it will also get rid of any “notes” or “meta-data” titles as well.

Does that help?

Yes, it was ticked. I have unchecked it and will try again. many thanks Keith.

Yes!! that got it. Thanks again.

While we are on the subject…
I want to print out the synopses for the whole document at the request of the publisher. Can you tell me what options I should choose to achieve this? Thanks

In the formatting pane of compile, just tick all the boxes in the “synopsis” column and deselect the others. (You may want to leave “title” checked to give you additional context for the synopses.) You can opt-click on a checkbox to select/deselect all the boxes in the column.

Perhaps I am not understanding something. Where is the synopsis column…?
Click for large view - Uploaded with Skitch

OK! found it. The formatting page!

Back Again!
Do I just have to do this on the formatting page or do I need other pages to be checked too? I have tried with just the formatting page checked and the contents page unchecked and get a blank page.

Sorry for being unclear. In the “Content” pane, which you pictured above, you need to select in the “include” column all the documents that you wish to have compiled. In this case, you need to choose all the documents whose synopses you want included.

Then, in the “Formatting” pane, check the “synopsis” box for all the appropriate file types. Looking at your picture, it appears you only have single documents (no folders or doc groups) so you could probably just choose that (for Level 1+), but unless you specifically know you do not want to compile folders or doc groups it’s probably just as well to check all the boxes in the column. (If you have documents set to compile that do not contain a synopsis, the compile will print “No Synopsis”–I think that may change for the next Scrivener update, but in the meanwhile if you see that, just uncheck that document from your “included” list and compile again.) If you want the titles included as well, check the boxes in the “title” column.

I really am grateful for all this help.
I think we are getting there. However as it stands this will print out, according to the PDF, 32 separate pages each with a brief synopsis. What I was looking for was a series of ‘paragraphs’ in which I had the chapter title and the synopsis for that chapter, then followed by the next chapter heading and synopsis ON THE SAME PAGE.
Again, many thanks!

Whoops. I almost included additional instructions on just that, but I was headed out and thought it might be going overboard… :slight_smile:

Two things to check, both in the Compile settings. First, on the “Contents” page, make sure none of the boxes are checked for “page break before.” Second, in the “Separators” pane, make sure none of them are set for “page break.” (If you are only compiling text documents and no folders, the only one that really matters here is the top one separating text from text, but it won’t hurt to set them all to just “empty line” or whatever custom divider you’d like.)

Many thanks. Complete success.
I am really very impressed at the level of support the Scrivener is providing through these forums.
Thank you again for you patience!