Compiling for Word or PDF with comments included

I’m trying to compile an article I’ve edited for someone as a Word document, or a PDF, which is fine, but the comments I’ve added for their attention - “New heading here?” “Is that the correct street name?” etc are not showing in the compiled version. How can I retain them in compiling?

In the options of the compile panel (top right side), there is an option to have them removed. See that it isn’t checked.

image

1 Like

Ah, thanks. It wasn’t actually on the right until I invoked it with one of the little icons on top right, then I had to uncheck it, change the display resolution in System Settings so I could see the bottom of the dialogue box (Thanks, Apple, not!) compile, go back and re-change the System Settings, and then compile it again now that it has the leave-out-comments bit unchecked. It’s a bit kludgy - the comments now appear inline, so I had to go down through the document highlighting each one, but it’ll do.
Thanks for the clarification.

In your compile format this time :

That is for a DOCX.
PDF doesn’t have that setting. You would have to make your comments rather be footnotes. There might be a compile setting for that, but I don’t remember where and can’t currently find it.

I don’t have a Section Layouts part like that, instead it’s like this - oh, wait, I can’t add an image here now…?

You should be able.
Make sure your image is of a compatible format. Like PNG, for e.g.

This is my Compile dialogue box - the Section Layouts looks different

These are the compile formats:
image

Double click the one you plan to compile with.
Duplicate if prompted to.
Then my previous screenshot will be relevant to you.

Which one would I use for an article that I want to be just a Word docx?

Good question.
You can do anything from any of them.

Say Manuscript (Times) should do fine.

That didn’t help much for some reason.

That’s the Mac dialog for setting where you want the comments to appear.

Mark

1 Like

When I double-click it this happens

Yep.
Duplicate and edit

No luck. Now it’s showing [1] or [2] etc within the document but it isn’t showing the comment.

Whatever app (Word?) must have its own setting to show them or not.
(Unless it is LO, this I can’t help with.)
Click on one of those numbers ?

If so there’s nothing I can do about it. Word certainly shows comments I make in Word itself as side comments.

See in your compile format if they are set as endnotes.
image

You could also look at the end of your compiled chapter or whole document.

They’re set as margin.

Do you currently see the comments panel in Word? Or not at all?
Add a comment ?