Compiling Formatting Options (indents)

I am having this behavior, which is odd:

When I compile to epub, I set the Formatting pane to Override text and notes formatting, and under Options, I select Remove First Paragraph Indents - At the start of each new document.

What happens is that the first 2 paragraphs are not indented. Starting with the third paragraph, indenting happens as desired.

I wonder if anybody else is seeing this, or if some other setting I have enabled is clashing here and resulting with the double-paragraph no-indenting?

  • asotir

Could you PM me a stripped-down sample project that demonstrates this issue? I can’t think of any settings offhand that may cause this result, so the problem is likely something that will require some probing about.

One thing I can think of to check immediately is the presence of line feeds instead of paragraph breaks, but the way you describe it, this sounds more procedural than occasional incorrect paragraph breaking.

Sorry Ioa, I don’t know how to PM you. But rather than preparing the longish project, I made a new one, just modifying the basic fiction Novel template (which is the template I used on the other). Compiled to epub and mobi, and the indents work as desired.

So it is not a Scrivener problem, but rather something in how I set up that novel. I can tell you that the issue is not one of line break vs full return, as I show invisibles and the epub has the first two paragraphs not indented. But in the editor pane, the Ruler shows the indents are there in the Scrivener doc.

One other thing of note is that I imported this project from an .odt file, into research, then split it up and moved the scenes and chapters into the Draft folder. But I expect my problem is that there is some other setting I have altered that messes things up.

Oh well. No big deal since there are plenty of ways to work around it. Maybe I will try to recreate the project by saving the .odt as .rtf and cutting and pasting into a new, clean, Scrivener project.

  • asotir

Definitely, under normal conditions what you are seeing should not be happening. I myself cannot create a condition where two paragraphs have their indent removed by the compiler, but there might be some factor I’m not thinking of.

So far I’m leaning toward some kind of formatting issue—you mention this text was originally composed in OpenOffice, so maybe something odd came from there that Scrivener’s RTF modification tools are not expecting. Based on that assumption, one thing you could try is nuking the formatting in one section that you know has the problem, and see if it persists. If it translated even though a plain-text paste, then my assumption about formatting gremlins is wrong.

Whether or not the problem originates in Scrivener, it could be still be something that we can patch over in anticipation of handling texts from sources that cause it. So either way a sample text document or two in a binder that reproduces the issue (you may need to transfer the compile settings to the sample project as well) could prove helpful.

P.S. The right-hand column in forum thread display has contact options below the user’s name. Everyone should have at least a PM button. You could also use my e-mail button if that is easier.