Compiling issue with container titles questions

Scrivener adds the titles for my copyright and dedication pages when I compile my eBook.

These are separate containers within my Draft.

I don’t want the title for my copyright and dedication to appear but I do want the titles of other containers to appear in my compiled ebook.

How can I compile my ebook so it add titles for some containers but not others?


The “Compile As-Is” checkbox in the Inspector is what you want for stuff like a dedication page. You will likely want custom formatting there anyway that you want to keep preserved, but since As-Is waives all Formatting pane settings for that item, it also will not acquire a title.

Consult chapter 23, Creating a Table of Contents, in the user manual for information on how to customise or generate a ToC for your e-book. Briefly, you want to create a document with a name matching the assigned name given to the contents section (in the Layout compile option pane, by default “Contents”) and put that in your Draft where it should appear. Now whatever you put into that file will be the visible ToC, you thus have full control over what appears.