Compiling issues w/ contents, font, and separators

Hi All,

I received a lot of help here on the forums when I first started with Scrivener back in February. And after many months of tinkering with the program, I LOVE it but I’ve come back because I need some more help. What has been giving me trouble is compiling ebooks.

I adjusted how I desire my ebook to look under Compile > Formatting and then compiled the ebook into a Kindle and epub version with the same settings. But here are my issues.

  • First, I’m getting a blank page after my table of contents in both the mobi and epub versions. I never had this issue before but now it’s appearing.

  • Next, for both versions I cannot seem to figure how to set it so that the text font can be adjusted by readers in their ereaders. Right now in both my Kindle and epub tests, the font is stuck as Times New Roman and as 12 pt because this what is selected under “Compile > Formatting > Level 1+> Modify.” How can I make it so a reader can choose or so that it uses an ereader’s default font.

  • Lastly, I’m having this issue with the epub file only. Some of my settings under “Separators” are not being reflected in my tests in both my Nook app and Aldiko app. I have selected page breaks to appear between folders which is working fine but “Single Return” setting I chose for the “Text Separator” is not working. Everything is jammed together. The Kindle version works perfectly with these settings.

I’ve searched around these forums, online, and read the help doc in Scrivener but if anyone can provide specific help to my issues I would be so grateful.

Thank you for your time and help!

Thanks for your kind words! Let’s see what we can do…

Marry, sir - I’m not automatically seeing the blank page following the TOC, so could you describe the settings for your compile, specifically for the first document in the binder? There may be a mixture of document type, what elements are set to compile in the Formatting pane (or if it’s set “as-is”), and what separators are used that’s causing this. (Which isn’t to say you’ve set something wrong, just that knowing how you have set things will help figure out what’s going on and reproduce it.)

Moreover - Likewise I’m afraid I’m not able to reproduce this. If I compile with TNR, for instance, when I open in the Kindle Previewer, it uses my default device settings, and I’m able to switch the font face and size as normal. What device are you using where changing the font settings isn’t working?

Sixth and lastly - I’m not seeing this in Adobe Digital Editions or Calibre, so this looks like it may be specific to those readers. I’ll have to download the apps to check it out. Which versions are you using? (PC? Android?) I’m not familiar with the Nook previewer–Kindle I know has the separate reading app and previewer app, but I’m not seeing that for the Nook. Do you know if the appearance in the app and on the actual device are one and the same?

[size=85]And to conclude, I just had a random Dogberry attack. Something about the lists and the lateness of the hour…[/size]

Hi,

Thank you for your help!

I figured out my first problem. I had an extra folder in my binder and since I have page break between folders I was getting an extra blank page. So easy fix there.

I’m using Kindle for PC for the mobi version. It allows me to change the text size easily but the font is appearing as Times New Roman instead of whatever the Kindle default font is that I see all my other Kindle books appear in.

For my epub version I’m using Nook and Aldiko on an Android device. The same problems are appearing in both ereading apps. Font style cannot be changed. Font size cannot be changed. And the spacing settings that I created in Compile are not being reflected.

I just downloaded and tested my epub version in Nook’s PC software and I’m getting the same issues as well so it has to be something with the epub file. Font size is not altering. Font type is Times New Roman and not the Nook default. And the space settings I created in Compile are not working.

Under compile I have my text to appear as Times New Roman and 12 pt font but I do not know how to change this so it appears in whatever size and font style the reader wants. And the issues with the spacing I set in compile I’m not sure at all how to fix because it is not an issue in my Kindle file when I test it in my Kindle PC software.

Appreciate the help.

I just wanted to make a quick update. I tried my epub file in Adobe Digital Editions and I’m having the same issues as in Nook and Aldiko.

I just wanted to give this a bump. I’ve been trying for days. Reading the manual. Watching tutorial videos. And searching this forum to see if there’s another thread about these problems. Still no luck. I know it’s got to be a simple fix.

Any ideas or suggestions would be greatly appreciated!

Thanks everyone.

UPDATE

As much as I would have liked to stick to Scrivener for all my needs from writing to compiling my manuscript into an ebook, I think I’ve made the decision to work in Sigil. Scrivener will be for organizing and writing, but Sigil seems to allow for more customization which Scrivener was never meant for. I’ve already tested a few of the issues I first posted above and have been able to fix them thanks to Sigil. It’s a lot of work messing around with the coding but I can do it with patience and perseverance.

Thanks for the help everyone!